Results 1 to 14 of 14
  1.    #1  
    My apologies if this has been answered, somewhere. Extensive searching hasn't turned anything up.

    I finally got my Sprint Frankenpre 2 up and running, last night. Yay! I've got full access to my old backups, all apps, phone/texts/data work great. Unfortunately, wifi won't turn on. I'm hoping it's not an error in my webOS2.1 doctor compile, since I'd rather not go through all the steps of doctoring back and forth, again.

    Has anyone run into this, before? How did you fix it? I've got unlimited data with Sprint, but wifi at home makes podcast downloads so much faster. I'd love to get my wifi back.

    Thanks for any help you can provide!

    -- Rebecca
  2. #2  
    happens frequently to my brother, and I with our Pre 2s... Device Restart or battery pull usually fix it.
  3. #3  
    do you have any of the experimental kernels installed? I've had my fair share of issues with wifi after having installed those
  4.    #4  
    I tried the restart and the battery pull. No love. It still just sits there and thumps, but never seems to start the service.

    No experimental OS, unless 2.1 is considered experimental. I just did a straight up Sprint Frankenpre 2.
  5. JimHuff's Avatar
    142 Posts
    Global Posts
    164 Global Posts
    I had this problem for an entire day after the FrankenPre operation. I tried numerous resets and battery pulls to no avail. On day 2 I tried another battery pull, but, this time, inserted a fresh, new, fully charged battery and it's been working great since then.

    I had the issue one time more on day 3, but a simple battery pull corrected the problem.
  6.    #6  
    Well, so far no luck. I've tried several battery pulls with full batteries, and I'm still getting the same thing. It's like the phone just doesn't recognise that it has a wifi card, at all. I've done a glance-over of the /etc/network/interfaces file, and everything seems in order... but I don't have anything to compare it to, either. iwconfig doesn't see any wifi devices, and ifup'ing wlan0 returns a complaint that it doesn't exist.

    Anyone have any thoughts based on all of that? Again, with no device to compare it to, I'm not sure what is considered "normal" on a Pre 2, or on a Frankenpre, so I don't know if I'm barking up the wrong tree, here.

  7. JimHuff's Avatar
    142 Posts
    Global Posts
    164 Global Posts
    I'm not expert, but, from what I gather, you probably need to doctor it.
  8. #8  
    yea I can bet you have to doctor. My wifi wasn't working anymore and nothing fixed it, not even a reset. Only a fresh doctor will cure your problem for good.
  9.    #9  
    Just an update to say that I'm still having issues, even after redoctoring. I've also found that Bluetooth is not working.

    Does anyone know the proper commands on the command line to get these two services back up?
  10. #11  
    Your metadoctor .jar could be corrupt or compiled incorrectly. Git pull, make clobber, and build the metadoctor from scratch. If that doesnt fix it, make sure the comm board is connected properly in both pin connectors. Commands wont fix this.
  11. #12  
    The wifi device is (oddly) called eth0, you won't find a wifi one there. ppp0 is the cell data one.

    The thread mentioned before works when the wifi starts but gets very low signal (happened to me once on my old Pre- after opening it to fix the front speaker).

    This said, it has to be a damaged or misconnected comm board. Check all the cables and connectors, I snapped a little strip of one of the ribbon cables that go to the display, the phone would power up but the modem ddn't respond, maybe it's a similar case.

    Also, since you'll open your phone again, have extreme care with the volume buttons ribbon. If you break that, you'll have to change that part, and it comes with the camera as well, so it won't be specially cheap.

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  12. #13  
    This is a common issue with FrankenPre. Happens to me quite often when returning to a hotspot and automatically reconnecting. Simple turn the wifi off and wait a minute or so. Then, turn it on again. Voilà. It's much easier if you have the wifi toggle in your device menu, via patches like Device Menu Megamix.
    I don't understand the purpose of the line, “I don't need to drink to have fun.” Great, no one does. But why start a fire with flint and sticks when they've invented the lighter?

    Let's all give thanks to the app that started it all.
  13. #14  
    Ive never experienced or heard of this issue before. Considering the OP has tried multiple restarts and a doctor, I am willing to bet its hardware related.

Posting Permissions