I have a Verizon Pre2. It had Preware and several patches installed - though I can't tell you which ones. The reason I can't is that yesterday it stopped downloading email messages and I was instructed to use "Erase Apps and Data" and then reconfigure mail. I didn't uninstall any of the patches before doing this.

Today after doing this I realized Preware was not longer installed. Found this because I went to use FreeTether and it wasn't installed. I re-installed Preware, FreeTether and all looks good. However tonight I tried to use my Flashlight from a patch I had downloaded before but I see "Error" on the menu and can't run it. Weird thing is I just tried to take a picture using my keyboard (another patch that I had installed before) and that does work.

Not sure what's going on - maybe I should have uninstalled my patches before I did the Erase Apps but things seem to be in a wierd state now. When I run Preware, it doesn't say I have any patches installed though I know some are there and are working (e.g. battery % indicator, already mentioned take picture with keyboard). Is there anything I can do to figure out what patches are installed? I didn't write down the patched I installed and am not sure which ones I had. I'm not sure I can install a different advanced menu patch with a flashlight without cause some other issue.