Page 1 of 2 12 LastLast
Results 1 to 20 of 27
  1.    #1  
    Hey everyone, I got my Pre 2 very recently and absolutely love it. It's the perfect webOS experience in my opinion. The difference between running a Pre- and a Pre 2 is night and day and I'm so glad I switched.

    However, I have a strange problem with my Pre 2. The GPS is non-existent! It's not a problem of inaccuracy, no it is a problem of absence. Google maps can't find my location, Gowalla can't find it. When I run the GPS interactive test, it says it can't get a signal. Running ##477# (GPS FIX) yields an error.

    Yes, I have GPS and Google location set to on. I've tried restarting and downloading the GPS fix app, with no solution. It's very bewildering. I'm within my 14 days with Verizon so I will try to get a new replacement.

    Has anyone experienced this? It seems like a hardware bug/failure and not software, but I'm not sure.

    I tried to doctor it, but I couldn't get the process to complete. If anyone has any tips regarding doctoring let me know. I got to the part where I plug in my Pre 2, but I am not able to click "next".
  2. #2  
    Turn off the phone and then turn it back on while holding the up volume button. That should boot it right into a doctorable state.
  3.    #3  
    Quote Originally Posted by FenrirWolf View Post
    Turn off the phone and then turn it back on while holding the up volume button. That should boot it right into a doctorable state.
    Is this while it is still plugged into my PC during webOS doctor program?
  4. #4  
    IIRC, you do it unplugged, then plug it in when prompted to.
  5.    #5  
    Thanks! I'll see if this helps.
  6.    #6  
    Not sure, when I plug it in, is it actually doctoring before I press next (thus it is unavailable to press), or AFTER I press next?
  7. #7  
    it's not doctoring until you see the progress bar. Just plug it in when you see the next button
  8.    #8  
    Hrm, seems like Win 7 64 bit has an issue with webOSdoctor/novacom. I'll see if I have more luck tomorrow, thanks fenrirwolf.
  9. #9  
    I have Novacom working on my Win7 x64 install. Hope you get it working on your end.
  10.    #10  
    Did some searching and thanks to the power of Jason Robitaille, I was able to install novacom!

    Here's the link to his easy installer:

    In the process of doctoring now. VZW is actually going to send me a new phone, but I figure I'll try this anyway to see if I can diagnose the problem (hardware or software) before I get a new one.
  11.    #11  
    Update: webOS doctor did not fix it.

    I got a replacement Pre 2 AND that one has a non-existent GPS also! What?!
  12.    #12  
    BTW, google locations does not work on either phone, so even triangulating by cell towers does not work (I assume that's how google locations works).

    Makes me think that's why it's a software issue, but the webOS doctor should have fixed it...
  13. #13  
    You didn't mention, but do you have a Verizon Pre 2? If so, try the old VZ Navigator trick, before starting Google maps.
  14. #14  
    I should have mentioned - the "trick" is to launch VZ Navigator, leave it open at the purchase screen, you don't need to purchase. While still open, you can launch other GPS apps like Google maps, etc.
  15. #15  
    I am having the same issue with my vzw pre2 (just bought used). Otherwise the phone works flawlessly. I haven't tried the navigator trick but was wondering if the OP had solved the problem?
  16. JJCook's Avatar
    191 Posts
    Global Posts
    205 Global Posts
    I have this issue intermittently with my Pre 2. Sometimes it is spot on and I can use Navit and sometimes it doesn't work at all. I have turned GPS off and on and have rebooted the phone. It works sometimes and not others. It seems that if I am inside for a while, it stops working when I go back outside. Frustrating...
  17. #17  
    My Sprint Pre 2 also has problems with navigation. Actually it is a frankenPre. Sometimes it works and sometimes it doesn't. My original Pre worked much better regarding nav. I have found that it helps to reboot, but i know you have already tried that.

    Most of the time, the sprint nav works fine, but other apps (like the one I wrote) will not find my location.
    NiceGPSuperior1 is a free GPS program, now with the ability to save your map! Get more info here. It's free! If you like this app and want to encourage development, you can donate from the web page link.

    NiceDrudgeReader is a fast, simple reader for The Drudge Report. It is only $0.99, so check it out, too! More info here.

    Search for "Nice" in the app catalog to see all my apps.
  18. #18  
    I also have a Sprint FrankenPre2 and the GPS is seriously screwed up, much like described in this thread.

    On a few occasions it has worked perfectly, but most of the time it is very inaccurate and most GPS apps will not work well (or at all) because of it.

    I really have no idea how to fix it. I meta-doctored it, but it didn't help at all.
  19. #19  
    I have the same issues with my unlocked GSM Pre 2.
  20. giggles's Avatar
    677 Posts
    Global Posts
    690 Global Posts
    mines weird. it goes off and on...
Page 1 of 2 12 LastLast

Posting Permissions