Results 1 to 3 of 3
  1.    #1  
    Hello everyone! I'm a n00b here and I need your help. Every time I'm trying to purchase an app in the catalogue, it says : Purchase failed / Data Entry / A required field does not exist or is empty. I used a gift card that HP they gave me when I bought the phone. I was able to buy a couple of apps, but then the problem appeared before I used all the money on it. I tried with my credit card, same problem. I tried every combinations possible for my address, but nothing worked. I even changed my address on the credit card site to be sure that is was written the exact same way.

    I found a similar tread on the forum but it wasn't any help. They said something about a profile that is 9.9.9 or something and my palm profile did not say anything like that. I called the palm help line and the guy did not understand the problem. I'm certain that you guys are more competent than they are.

    For your information, I'm running a Palm Pre 2 with WebOS 2.1 on Rogers.

    I love WebOS and really want to support the developers by buying my apps, but if there is no way to pay for it, I will have to get them another way.

    Thanks in advance for your help and sorry for mediocre English skills... I'm French-Canadian.
  2. gregp's Avatar
    265 Posts
    Global Posts
    268 Global Posts
    Bump. Got this myself with a new AU profile (set up on a Pre 3) and now logging into on the Veer. Found something on


    Hi there, im trying to add my Com Bank Master Card Debit Card and keep getting 'data entry: a Required field is empty or does not exist'

    I have gone over it 10 times and am sure I have done everything right.

    Any ideas where I could be going wrong?


    Had to update the app store


    But my app catalog is already up to date. Help?!!
    Last edited by gregp; 04/19/2012 at 10:28 AM.
  3. gregp's Avatar
    265 Posts
    Global Posts
    268 Global Posts
    OK found a solution to this. This is for Australia only but may work for other countries. It seems the credit card billing address requires a 'State' field in Australia, however this field is not requested on the credit card setup on the phone version - but it's still required! So obviously no data gets entered in a non-displayed field, and because the field's empty it throws this error message! Marvellous. Other countries may also have 'required' fields that are 'hidden' and causing this problem.

    The workaround was to set this data up on the webOS account in question on a Touchpad as the State field IS requested on the Touchpad. It was only when I tried on the TP that I saw the extra field being requested, and being populated it went through on the TP and then refreshed the phone screen and the card was set up there too.

    Hope this helps someone save a few hours of their life.

Tags for this Thread

Posting Permissions