Quote Originally Posted by grankin View Post
Bugs? Or 'features"? My Pre2 (runs 2.2.4, is a GSM version) has been replaced by HP, has had a new profile created, and still would not dial out. Key in a number, it appears, hit 'dial' and the phone icon panel flashes yellow-green and it quits. Wiped clean twice, doctored four times. Then, after I set it aside & used the Pre+ while traveling, it (miraculously) revived itself. Nevertheless, it occasionally refuses to accept a new contact, will not allow any phone number type to be assigned except 'mobile', and will not allow a default contact list to be assigned.
I am this close to wiping it, putting it on ebay and waving 'good-bye' to it ... though the new OS has some nice features that the Pre Plus (running 1.4.5, after a brief - but nasty - flirtation with 2.2.4 that HP tried to foist on me) does not have (like being able to run a few spiffy apps and being able to assign new 'cards').

I like the size of the device, and it works reasonably well as a phone. I may keep the PrePlus and stick with it ... or I may use the money from selling the Pre2 to get a similarly-sized Android phone. The Wildfire S is not at all bad,and new small Android phones seem to be coming out of the woodwork - though targeted at teenaged girls, it seems.
The mystery has been solved! HP's engineers have been through the deepest phone logs that could be extracted from the device. It seems that the SIM card was the culprit. It ran fine on the PrePlus, but not on the Pre2. Then I managed to lose it while swapping cards in Panama. AT&T sent me a new one.

Guess what? It now works. We had (again) to wipe my stored profile, wipe all apps and data, and rebuild, because there was another possible gremlin in the DTA attempt to copy contacts, for it left a persistent contacts account that was otherwise not deleteable. With the wipe, it is now working the way it ought to.

HP's tech, Shane, deserves recognition for a job very well done.