Page 2 of 2 FirstFirst 12
Results 21 to 38 of 38
  1. #21  
    treo_knight: I don't have a Pre2, but I do manage mail servers and networks all day, so I can talk about that but can't give you specific directions on the Pre2.

    I would say that your IMAP is working if it is working for the other email accounts. You also said the SMTP port was changed from 25 to something else, that isn't going to go into effect until you send out an email. So let's focus on receiving the folders.

    First get Terminal (was written for the Pre, might work on Pre2)
    Application:Terminal - WebOS Internals

    Then you want to from your Pre2 telnet to your server, but use port #143.
    You should get a response from the server. If you don't, then your not getting connected to your mail server (try fulldomain name or IP address). Also if you are not then contact your Email Administrator and have him monitor/tail the log file to see if you are getting connected.

    If you are getting a response then type the following;
    1) LOGIN username password
    2) LIST "" *
    3) SELECT mailbox

    Line 2 shows you all available mailboxes.

    To show the information about a mailbox:
    4) STATUS mailbox (MESSAGES)
    Between () you can place one or more of the following: MESSAGES, UNSEEN, RECENT UIDNEXT UIDVALIDITY

    And one of the following commands to view the a message 1 is the first message * is wildcard for all:
    5) FETCH 1 ALL # All IMAP headers
    5) FETCH 1 FULL # Full headers and body info
    5) FETCH 1 BODY # Body
    5) FETCH 1 ENVELOPE # Envelope
    5) FETCH * FULL # All email

    If you get stuck on #1 try either your username only or full email address.

    Lastly, check with your Email Administrator if ActiveSync is also an available option which should be if you they are running Exchange, GroupWise or Notes to name a few...
  2. #22  
    I had a similar problem with my main (gmail) account after upgrading my Sprint Pre Plus to 2.1. The other accounts worked fine, but my main gmail account would not. I would get the syncing circular icon in the dashboard and then nothing. In the email app, none of my folders were there.
    I fixed it by doing the following:
    1) Go to the "accounts" app
    2) Turn off email on the account that is not working correctly
    3) Wait a bit, exit the app
    4) Restart phone
    5) Go back to the "Accounts" app
    6) Turn email back on.

    Voila! Worked for me.
    Hope this works for you. Thanks for being so loyal to Palm. I've been with Palm since the first U.S. Robotics Palm Pilot.
  3.    #23  
    Hi Guys, apologies for not giving feedback earlier. I am travelling these days without the defunct Pre 2 so unable to check out the suggestions.

    gnark: I have not got around to putting Preware and subsequently lumberjack so this option is still open. I did install lumberjack on my Pre(-) and looked at the logs. It just shows the IMAP login and there seems to be nothing extraordinary as the mailbox on the Pre(-) works without a hitch.

    ttoepp71: Your suggestion brought the strongest ray of hope but after some playing around I'm not too sure now. I activated telnet on my Win7 laptop and ran through all of the steps listed in your post. Everything worked as you had indicated. LOGIN, LIST, SELECT, STATUS, etc all of them give the expected results onscreen.

    Then I installed "Terminal" on my Pre(-). I was able to telnet the server and it gave me the expected results of "* OK Domino Server Release 8.5........" but after I entered my login details there was no response. The cursor would move down one line after I pressed enter and then nothing. I tried dozens of sessions but each time i got the same result. I'm not sure if this is because of some sort of deficiency in the alpha terminal utility for webOS or it has something to do with the login protocol the device uses or there is some odd setting on our server which we need to correct.

    rogerkang: your solution I was able to try on the Pre2 even before I left on this trip as it was an easy option. Oddly enough if I went to the "Accounts" tab on the Pre2 (Pre minus and plus owners in reading this feature is not there in webOs 1.4.5 so please do not be confused) I can see the problem mailbox account. I also see the slider switch of "Use Account With -> Email -> On" but try as a might i cannot slide this switch from "On" to "Off". I deletes account and created it again. I did this through Email App. Then tried creating account through this Accounts App. Each time the account would get created but I cannot change its status from On to Off. So go figure?? I think it probably has something to do with the fact that this new account never gets properly validated on the device (or something to that effect) so you cannot change its status as well. I can however "remove" and "add" the account through both the Email as well as the Accounts tab.

    Lastly, a kind soul from the forums has PM'ed me and he either has a connection to Palm reps or he is with Palm. He has suggested creating a test account in our corporate mail server and give them username and pwd access to this account to play with it from their end to see what comes up. Our IT guys are not really happy with doing this for obvious reasons. They don't want anyone poking around making test connections to the server outside of the DMZ. Imagine having to do all this in a corporate IT setup in Europe in a 100% BB environment for one pesky user somewhere in China who insists on using his new dysfunctional Pre2 :-( So I'm not in the strongest of positions to get this done immediately but I'm working on it and if they relent we will try another session of troubleshooting soon.

    I have to say some of us Palm loyalist's are tenacious. Don't you agree. An average John/Jane Doe would have long since chucked the Pre2 out of the window. Actually he/she would not have bothered with the Pre2 at all after the disastrous hardware and battery limitations of the Pre (-) but I'm definitely going to go down fighting on this one. There's still hope...........................I hope
  4. #24  
    Have you ever tried turning on encryption for your imap server? I'm not sure if the IT guys are willing to do it, but maybe the Pre2 has issues with unencrypted imap connections?
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  5. #25  
    Hm, Lotus Notes? I found this page regarding a similar problem on an Android email client Issue 1862 - k9mail - IMAP configuration with Lotus Notes 8.5.1 does not show any messages - K-9 Mail is an advanced email client for Android - Google Project Hosting

    which suggests setting it to sync "all" emails instead of by number of days.
  6. #26  
    I got Palm Pre 2, works fine, mostly emails, which I have several accounts. I used iPhone 4 but Palm pre 2 is much more better with emails and other notifications then iOS 4.0.

    The big problem for me is applications, I miss many of them which I used well on iPhone, I will wait for Pre 3 and if there will be not major improvement I will move back to iPhone.
  7.    #27  
    frantid: I have sent a request to our IT guys to let me have the option to log in with encryption switched on. I hope they allow me this experiment. The only problem is there are a few other users who log into this mail server and a global setting change on the server side would mean everybody has to change their settings. I guess if it works I could still looking at having this change pushed out for everyone. Will keep everyone posted on progress (if any).

    greenoyster: I tried that option to sync "all" mails and it does not work.

    ttoepp71: I finally got Preware installed on the the Pre2 and installed "Terminal". Apparently Terminal does not work with WebOS 2. The black screen comes on but I cannot see any text characters onscreen. I tried all font options, changed background colour schemes, etc. no luck. Are there any other Terminal like apps?

    Project Lumberjack: So I installed Lumberjack and here are the Email App errors. Unfortunately they make no sense to me.

    ! EXCEPTION [CM got response from unexpected link]:
    Error at Object.<anonymous>
    (palmInitFramework298:811:418) at
    (palmInitFramework298:778:416) at
    (palmunderscoreVersion1_0:116:238) at [object
    Object].getItemsToRender (palmInitFramework298:753:335) at
    (palmInitFramework298:851:518) at Array.0
    (native) at [object Object].<anonymous>
    (palmInitFramework298:774:229) at
    Object.gotResponse (native) at
    (palmInitFramework298:778:148) at
    ! ----------- CreateAssistant createError error=Wizard:
    Unable to determine settings
  8.    #29  
    I deleted the account and tried to set it up again. Another new error I get to see in Lumberjack is as follows:
    ! Composeassistant.replaceCIDs:
    not currently implemented

    So anyone out there who can throw some light on this issue?
  9. #30  
    Rather than terminal, try using putty to connect in in developer mode (I don't have the instructions on how to do that immediately to hand; but I'm sure someone here will help if you can't find them). Putty is a lot more user friendly for this sort of job than terminal anyway (in my opinion) and then telnet from that
  10. #31  
    This is a long shot, but I've noticed the following behavior with IMAP under 1.4.5. Anytime someone sends me an email with an attachment of a second email, the email client shows an error and will not download any new messages for the account. Removing the email with the attachment from the folder (from a different client than the phone) makes service resume.

    I figured this out by removing all emails from the folder until I figured out what the culprit was. This may not be the case for you, but you could try removing all emails from your imap account (put them in a folder that doesn't sync), and see if that gets you in. Then if it does, you can start moving your mail back in bulk until you find the problem email.
  11. #32  
    If you go into email prefs & accounts, can you see your folder settings for Inbox, Drafts, Sent folders for that account.
  12.    #33  
    William_MPLX: Ok. Now I'm at a complete loss. I don't know a thing about linux. I googled puTTY and it seems to be an alternative way to root your Pre and get access to it. but I thought with Terminal we were supposed to look at connection logs between the Pre and our corporate email server which is thousands of miles away on Windows Server someplace. If I get root access to my Pre from my PC or laptop using puTTy I don't see how it would help to solve the email problem. Or maybe I just don't understand this bit and root access will allow some sort of access to look at connection logs. Anyway the bottom line is this looks a bit intimidating and will probably require time and patience. I''l get to this if I really have no other options left.

    dsalonius: I can confirm that the mailbox in question or any particular email in it is not a culprit for 2 reasons:

    A. I have the same mailbox syncing flawlessley on a Pre(-) with 1.4.5 and this remians my primary phone and email device to date.

    B.: I tried to set up another colleague's account on the same server. The results were exactly the same. On the Pre9-) we had no trouble configuring it but on the Pre2 no sync folders showed up.

    frantid: Yes, in the problem email account when I go to pref & Accounts I see "Sent", "Draft" and "Trash" folders. In a working account when you click on any of these you can change the location of these default folders by selecting another folder from the list of all folders displayed from that mailbox. But in my case I don't get to see any dropdown list of folders. All that's visible is "Inbox" and "Outbox". as I have stated above the SMTP relay is working fine. If a draft an email message it appears momentarily in the Outbox and then disappears after the email has been relayed. The recipient receives the email as well.

    I really really need to find a solution to this problem. Its bugging me to no end that its over 3 weeks now and my new Pre2 is sitting idle doing nothing.
  13. #34  
    Putty is (unfortunately) only a step in the chain to investigate what is going on. If you don't want to try it yet, that works for me, because I don't have time to explain it/talk you through it at the moment either!
  14. #35  
    well putty is just another way to watch (and hack) the guts of the phone. putty is a "ssh" client, thats like a dos-box in windows but operated remotely. if you put your phone into developer mode and connect it via usb (and select just charge) i think you can make a ssh connection to localhost at some strange port i forgot (anybody who knows it please post here). but in my eyes it will not help you asuming lumberjack does the same: inspecting a logfile and print it out to a place you can see it: the screen.

    hmm looks like there is no service error but a render error in javascript.

    i think the folders reported by the imap account have something unexpected in it. let it be the name or some attribute. probably its a result of the mirroring a different account to imap, some strange internal or hidden thing that the renderlogic cannot handle or filter out.

    if you ask me: its a bug in webos 2.x

    you should file it there, telling them: what imap mail server and how it was mirrored from lotus or exchange, the error stack trace you posted above.

    very likely this issue will not be adressed unless more users suffer the same problem. it is suspected that the problem is a result of your very individual account/imap setup.

    what you can do to help the community help you (someone who is willing to investigate the issue and probably can build a patch that will workaround the issue):

    1) setup a dummy imap account on that very server and make sure the problem does persist and is reproducable. let there only be dummy data anybody can see.

    2) find someone here that owns a webos 2.x device and is capable of debugging javascript os code and patching the os.

    3) give the address, login and password to that person (dont post it for everybody as you might end up with several people messing around with it) so she or he can reproduce the behaviour and find out what is to be patched to make that particular situation work.

    still i could be wrong and the error occures in a java service or even native compiled code, in this case things will get a lot harder to debug, but to me it looks like frontend jsjsjs $code$.

    here the chances of someone helping will increase when more people run into the same issue.
  15.    #36  
    If anyone is still following this thread here's an update:

    gnark: First of all a big thank you for a very helpful post. From what I gather this seems to be a webOS 2.1.0 bug. In general my feeling is that the email client in webOs 2 is very flaky and a partially finished product. In any case I still did not manage to get our IT guys to set up a test account for 3 reasons. One, they are not too keen to have outsiders poke around. Two, I'm not really sure I could get an HP-Palm rep to trouble shoot this for me. Three, an interesting alternative option came up so i went chasing that instead.

    The new Domino server has an accompanying option to activate ActiveSync using Domino "Traveler". This basically acts in a manner similar ActiveSync between Exchange and WinMO, Android, iOS devices. (In fact IBM has licensed ActiveSync from MS.)

    Our IT guys were being arm twisted to deploy Traveler because some Senior management had acquired Ipads and wanted their corporate email on them. I asked the IT guys if webOS was supported and after speaking with their external "Notes Consultant" (yes they actually have a highly paid outside consultant to help them manage and service this lousiest of lousy mail management system called Notes but that's another story and I digress). I was told he is not aware of anything called webOS and that it was definitely not supported. It then occurred to me that the Pre has pre-configured (no pun intended) Exchange connection options available. Since the backbone of this Domino Traveler conduit would be ActiveSync it might work with setting up an Exchange account but using our corporate IP settings for the server IP.

    To cut a long story short I had the IT guys set up and activate my traveler account. I entered all the settings on my Pre2, held my breath and pressed "Sign-In". Voila!!! Not only did the mailbox fire up I also got connected to "Contacts" "Calender" and "Tasks" on our primary mail server.

    One drawbacks was that only the "Inbox" would sync and the individual folders would sync only if I opened the folder and then the server sync for that folder would get initiated. But this is a limitation of the webOS mail client because the same behaviour is exhibited for all IMAP accounts nad their respective folders other than Inbox. I started the whole process of individually synchronising each folder ( I have a humongous folder tree) and simultaneously preparing my Pre2 by installing all the other patches and tweaks that I would need for daily use (had not done that because the Pre2 was not going to be in use unless my primary corporate email works).

    So here I am happily working on my Pre2 late into the night expecting to merrily come to work the next day armed with a fully functional pre2 and a soon to be in retirement Pre(-). What I was not aware of was the fact that while i was doing all this our external "Notes Consultant" in Europe was working with our IT guys to get the Domino Traveler thing to work with the iPad. The iPad had been stubbornly refusing to sync mail for 2 weeks now. They came to the conclusion that the users mail db on Domino needed to be upgraded to a new db version. Apparently after the mail db upgrade iPad's would get flawless connections to the mail server. So while I was sleeping with a smile on my face in Shanghai they upgraded my mail db to the new version in Europe. I wake up in the morning and see that new emails which came overnight appear in the mailbox but when I open them I get the issue so many users complained of in 2.0 and 2.01 "retrieving mail text" icon for 20-25 seconds and then "Error" cannot download email text.

    I read in horror an email from our IT guy (on my Pre-) informing me that they have upgraded the mail db and have still had no luck with the iPad but hopefully I will see improved and faster sync on my Pre. The irony of it all.

    I was still hoping that this email retrieve text problem might have been caused by one of the patches i installed. So this morning back to the basic troubleshooting and elimination options.

    1. Deleted problem account and set it up again. No luck.
    2. Did a partial erase and setup email account again. No luck.
    3. Finally doctored the Pre2 and tried setting up the account again. No luck.

    So I am back to having an email crippled Pre2. I have written to the IT guys to check if they can restore my old mail db again. They just wrote to me that the concerned person is out of office today so I have to wait until tomorrow afternoon. All I can say is why me???????

    On a last note if anyone needs help in setting up ActiveSync on the Pre with a Domino (>version) 8.5.1 I would be happy to walk you through the steps.

    Oh and I discovered another app on webOS internals called "Terminus". I have not played with it but maybe it does the same job as "Terminal" and actually works with webOS2. Just mentioning it here in case any fellow victim needs to use it as a troubleshooting tool.
    Last edited by treo_knight; 04/28/2011 at 02:11 AM.
  16. mullern's Avatar
    117 Posts
    Global Posts
    144 Global Posts
    Hi, there is a very knowledgeable guy on Lotus Notes in these forums with name GREGG. Search the Synergy forum for Lotus Notes and you will find him.
  17. #38  
    Well it really depends on the version of ActiveSync that the Traveler is running. On our email server there was specific versions that I could support so some of the original Droids had to actually run a program called Touchdown to simulate ActiveSync version 2.x where the Droids where natively running a 1.x version of ActiveSync. As long as the Server in question supports a fairly recent version of ActiveSync it doesn't matter if the overpaid outside consultant knows anything about WebOS or Droids, it just has to speak the protocol...

    Now on your Folder Access; Ask your IT Admin if your account has been setup to sync more then just the basics, likely you will be unable to synch "shared" folders that come to you from the Company, but if you have sub folders within your Inbox those should be accessible unless they are restricting it at the Server side and your IT Admin will be able to answer that question...
Page 2 of 2 FirstFirst 12

Posting Permissions