Page 1 of 2 12 LastLast
Results 1 to 20 of 31
  1.    #1  
    okay so i received my pre2 today and i am going to attempt to swap comm boards.

    i used show properties app from preware emailed myself the tokens.

    what is the next step that i need to take.

    do i swap comm boards first or do i do the software side first?

    if anyone would be willing to help me through the phone please pm me.
  2. #2  
    The process for the Sprint Pre 2 has been simplified. You don't have to extract the tokens, just run a script created by the good folks over at webOS Internals. It doesn't really matter which one you do first, but you may want to set up the software first. That way when you are done with the hardware swap, you can just plug it in and doctor it.

    Here’s the link to the picture guide for the com board swap.
    Sprint Pre 2 - WebOS Internals

    Here’s the link to walk you through the meta-doctor process:
    WebOS 2 Upgrade - WebOS Internals

    If this is your first time doing this (I’m assuming it is based on your post), I’d suggest you pay attention and read the wiki thoroughly; as it states in the overview:
    You must read this page from top to bottom twice before starting this procedure. You must complete all steps from 0 to 6. Do not omit any steps. Do not improvise. Do not think you can ignore the instructions. If you do not follow these instructions precisely, completely and without error, you will not achieve your goal and you will annoy a lot of people with a lot of unnecessary questions in the process.
    If you read it and follow the instructions you shouldn’t have a problem. It was all new to me, and I was able to do it successfully on my first try. Just take your time and don’t rush it. Then you’ll be enjoying an awesome new Franken pre 2, and while you’re still super excited make sure you complete step 6.
  3.    #3  
    thank you so much for replying. i downloaded cygwin and the packages that it calls for.
  4. #4  
    You're welcome, no problem.
  5.    #5  
    okay so i ran the script and now its creating my custom doctor. do i swap comm boards now?
  6. #6  
    Yeah, I would do it now. It will take you longer to do the swap, then it does for the doctor to be built. Start swapping if you haven't done so already.
  7.    #7  
    im doing the swap as right now got pre2 disassembled tearing apart sprint pre-. thanks for replying hopefully u will still be on to see if im successful.
  8.    #8  
    finished downloading and resulted in an error 123
    how do i fix it?
  9.    #9  
    $ ls ./scripts/
    ls: cannot access ./scripts/: No such file or directory

    $ git clone git://
    Cloning into meta-doctor...
    remote: Counting objects: 1117, done.
    remote: Compressing objects: 100% (1092/1092), done.
    remote: Total 1117 (delta 714), reused 0 (delta 0)Receiving objects 42% (470
    Receiving objects: 100% (1117/1117), 169.87 KiB | 172 KiB/s, done.
    Resolving deltas: 100% (714/714), done.

    $ cd meta-doctor

    NAVA@NAVA-HP ~/meta-doctor
    $ mkdir downloads

    NAVA@NAVA-HP ~/meta-doctor
    $ ls ./scripts/

    NAVA@NAVA-HP ~/meta-doctor
    $ ./scripts/meta-sprint-franken-unlocked-pre2-2.1.0
    DEVICE = pre2
    CARRIER = wr
    VERSION = 2.1.0
    CUSTOM_CARRIER_TARBALL = carrier.tar
    CUSTOM_BOOTLOGO = scripts/WebOS-Internals.tga

    Your custom doctor file will be created at build/meta-sprint-franken-unlocked-prprpr
    100%[======================================>] 188,386,871 175K/s in 18m 3s
    --2011-03-30 21:17:40--
    2011-03-30 21:35:42 (170 KB/s) - `downloads/webosdoctorp102verizonwireless-2.0.1
    .jar' saved [188386871/188386871],
    --2011-03-30 21:35:43--
    Resolving (,
    5ength: 188386871 (180M) [application/octet-stream]
    Connecting to (||:80... conn
    HTTP request sent, awaiting response... 200 OK41,331,140 175K/s eta 13m 46s
    Length: 197253671 (188M) [application/octet-stream]
    Saving to: `downloads/webosdoctorp103ueuna-wr-2.1.0.jar'

    100%[======================================>] 197,253,671 175K/s in 18m 29s

    2011-03-30 21:54:12 (174 KB/s) - `downloads/webosdoctorp103ueuna-wr-2.1.0.jar' s
    aved [197253671/197253671]

    rm -rf build/pre2-p102eww-verizonwireless-2.0.1
    mkdir -p build/pre2-p102eww-verizonwireless-2.0.1
    cp downloads/webosdoctorp102verizonwireless-2.0.1.jar build/pre2-p102eww-verizon
    ( cd build/pre2-p102eww-verizonwireless-2.0.1 ; \
    unzip -q webosdoctorp102verizonwireless-2.0.1.jar META-INF/MANIF
    EST.MF com/* \
    resources/webOS.tar resources/recoverytool.config )
    ( cd build/pre2-p102eww-verizonwireless-2.0.1 ; \
    unzip -q webosdoctorp102verizonwireless-2.0.1.jar resources/veri
    zon.tar )
    mkdir -p build/pre2-p102eww-verizonwireless-2.0.1/webOS
    tar -C build/pre2-p102eww-verizonwireless-2.0.1/webOS \
    -f build/pre2-p102eww-verizonwireless-2.0.1/resources/webOS.tar
    cp scripts/WebOS-Internals.tga build/pre2-p102eww-verizonwireless-2.0.1/webOS/Bo
    mkdir -p build/pre2-p102eww-verizonwireless-2.0.1/carrier
    tar -f build/pre2-p102eww-verizonwireless-2.0.1/resources/verizon.tar -t \
    > build/pre2-p102eww-verizonwireless-2.0.1/carrier/carrier-file-
    tar -C build/pre2-p102eww-verizonwireless-2.0.1/carrier \
    -f build/pre2-p102eww-verizonwireless-2.0.1/resources/verizon.ta
    r -x
    gunzip -f build/pre2-p102eww-verizonwireless-2.0.1/webOS/nova-cust-image-roadrun
    mkdir -p build/pre2-p102eww-verizonwireless-2.0.1/rootfs
    tar -C build/pre2-p102eww-verizonwireless-2.0.1/rootfs --wildcards \
    -f build/pre2-p102eww-verizonwireless-2.0.1/webOS/nova-cust-imag
    e-roadrunner.rootfs.tar \
    -x ./usr/palm/applications/ ./usr/lib/ipkg/
    info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info ./md5sums*
    touch build/pre2-p102eww-verizonwireless-2.0.1/.unpacked
    rm -rf build/pre2-p103ueuna-wr-2.1.0
    mkdir -p build/pre2-p103ueuna-wr-2.1.0
    cp downloads/webosdoctorp103ueuna-wr-2.1.0.jar build/pre2-p103ueuna-wr-2.1.0/web
    ( cd build/pre2-p103ueuna-wr-2.1.0 ; \
    unzip -q webosdoctorp103ueuna-wr-2.1.0.jar META-INF/MANIFEST.MF
    com/* \
    resources/webOS.tar resources/recoverytool.config )
    ( cd build/pre2-p103ueuna-wr-2.1.0 ; \
    unzip -q webosdoctorp103ueuna-wr-2.1.0.jar resources/wr.tar )
    mkdir -p build/pre2-p103ueuna-wr-2.1.0/webOS
    tar -C build/pre2-p103ueuna-wr-2.1.0/webOS \
    -f build/pre2-p103ueuna-wr-2.1.0/resources/webOS.tar -x
    cp scripts/WebOS-Internals.tga build/pre2-p103ueuna-wr-2.1.0/webOS/BootLogo.tga
    mkdir -p build/pre2-p103ueuna-wr-2.1.0/carrier
    tar -f build/pre2-p103ueuna-wr-2.1.0/resources/wr.tar -t \
    > build/pre2-p103ueuna-wr-2.1.0/carrier/carrier-file-list.txt
    tar -C build/pre2-p103ueuna-wr-2.1.0/carrier \
    -f build/pre2-p103ueuna-wr-2.1.0/resources/wr.tar -x
    gunzip -f build/pre2-p103ueuna-wr-2.1.0/webOS/nova-cust-image-roadrunner.rootfs.
    mkdir -p build/pre2-p103ueuna-wr-2.1.0/rootfs
    tar -C build/pre2-p103ueuna-wr-2.1.0/rootfs --wildcards \
    -f build/pre2-p103ueuna-wr-2.1.0/webOS/nova-cust-image-roadrunne
    r.rootfs.tar \
    -x ./usr/palm/applications/ ./usr/lib/ipkg/
    info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info ./md5sums*
    touch build/pre2-p103ueuna-wr-2.1.0/.unpacked
    rm -rf build/meta-sprint-franken-unlocked-pre2-2.1.0
    make unpack patch pack
    make[1]: Entering directory `/home/NAVA/meta-doctor'
    rm -rf build/meta-sprint-franken-unlocked-pre2-2.1.0
    mkdir -p build/meta-sprint-franken-unlocked-pre2-2.1.0
    cp downloads/webosdoctorp103ueuna-wr-2.1.0.jar build/meta-sprint-franken-unlocke
    ( cd build/meta-sprint-franken-unlocked-pre2-2.1.0 ; \
    unzip -q webosdoctorp103ueuna-wr-2.1.0.jar META-INF/MANIFEST.MF
    com/* \
    resources/webOS.tar resources/recoverytool.config )
    ( cd build/meta-sprint-franken-unlocked-pre2-2.1.0 ; \
    unzip -q webosdoctorp103ueuna-wr-2.1.0.jar resources/wr.tar )
    cp webOS.tar build/meta-sprint-franken-unlocked-pre2-2.1.0/resources/webOS.tar
    cp carrier.tar build/meta-sprint-franken-unlocked-pre2-2.1.0/resources/wr.tar
    mkdir -p build/meta-sprint-franken-unlocked-pre2-2.1.0/webOS
    tar -C build/meta-sprint-franken-unlocked-pre2-2.1.0/webOS \
    -f build/meta-sprint-franken-unlocked-pre2-2.1.0/resources/webOS
    .tar -x
    cp scripts/WebOS-Internals.tga build/meta-sprint-franken-unlocked-pre2-2.1.0/web
    mkdir -p build/meta-sprint-franken-unlocked-pre2-2.1.0/carrier
    tar -f build/meta-sprint-franken-unlocked-pre2-2.1.0/resources/wr.tar -t \
    > build/meta-sprint-franken-unlocked-pre2-2.1.0/carrier/carrier-
    tar -C build/meta-sprint-franken-unlocked-pre2-2.1.0/carrier \
    -f build/meta-sprint-franken-unlocked-pre2-2.1.0/resources/wr.ta
    r -x
    gunzip -f build/meta-sprint-franken-unlocked-pre2-2.1.0/webOS/nova-cust-image-ro
    mkdir -p build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs
    tar -C build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs --wildcards \
    -f build/meta-sprint-franken-unlocked-pre2-2.1.0/webOS/nova-cust
    -image-roadrunner.rootfs.tar \
    -x ./usr/palm/applications/ ./usr/lib/ipkg/
    info ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info ./md5sums*
    touch build/meta-sprint-franken-unlocked-pre2-2.1.0/.unpacked
    rm -f build/meta-sprint-franken-unlocked-pre2-2.1.0/.patched
    [ -d patches/webos-2.1.0 ]
    if [ -f build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/md5sums.gz ] ; then
    gunzip -c < build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/md5su
    ms.gz > build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/md5sums ; \
    mv build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/md5sums build/meta-sprin
    mkdir -p build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/var/gadget
    touch build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/var/gadget/novacom_en
    chmod -x build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr/bin/uploadd
    chmod -x build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr/bin/contextupl
    chmod -x build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr/bin/rdxd
    for app in ; do \
    ( cd build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs ; \
    find ./usr/palm/applications/$app -type f | xargs md5sum ) \
    > build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr/lib/ipk
    g/info/$ ; \
    ./scripts/ \
    fo/$app.md5sums.old build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr/lib
    /ipkg/info/$ \
    > build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr/lib/ipk
    g/info/$app.md5sums ; \
    rm -f build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr/lib/ipk
    g/info/$app.md5sums.old build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/usr
    /lib/ipkg/info/$ ; \
    ( cd build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs ; \
    find ./usr/palm/applications/ ./usr/lib/ipkg/info
    ./etc/ssl ./usr/bin ./boot ./lib/modules ./etc/palm-build-info -type f | xargs
    md5sum ) \
    > build/meta-sprint-franken-unlocked-pre2-2.1.0/rootfs/
    md5sum: ./usr/bin/basename: Permission denied
    md5sum: ./usr/bin/cmp: Permission denied
    md5sum: ./usr/bin/cryptpw: Permission denied
    md5sum: ./usr/bin/expand: Permission denied
    md5sum: ./usr/bin/head: Permission denied
    md5sum: ./usr/bin/ipkg: Permission denied
    md5sum: ./usr/bin/logger: Permission denied
    md5sum: ./usr/bin/passwd: Permission denied
    md5sum: ./usr/bin/renice: Permission denied
    md5sum: ./usr/bin/sha1sum: Permission denied
    md5sum: ./usr/bin/taskset: Permission denied
    md5sum: ./usr/bin/tee: Permission denied
    md5sum: ./usr/bin/traceroute: Permission denied
    md5sum: ./usr/bin/unexpand: Permission denied
    md5sum: ./usr/bin/whoami: Permission denied
    md5sum: ./usr/bin/[[: Permission denied
    make[1]: *** [build/meta-sprint-franken-unlocked-pre2-2.1.0/.patched] Error 123
    make[1]: Leaving directory `/home/NAVA/meta-doctor'
    make: *** [all] Error 2

    NAVA@NAVA-HP ~/meta-doctor
  10. #10  

    git pull

    make clobber
    then run the script again.
  11.    #11  
    okay will try. thanks for reply
  12. #12  
    Thanks for chiming in Psychonaut. I was fortunate enough not to get any errors when I did it, so I wouldn't have been able to say what went wrong. Hopefully this straightens it out.
  13.    #13  
    i did and same thing happened
  14.    #14  
    i really appreciate everybody chiming in and helping.
  15. #15  
    Are you still getting the same errors? I wish I could help more, but after looking at the log you posted, I'm not sure what will correct your error. I was fortunate not to get any errors. Until someone more experienced can look at the log & figure out what's causing the error, I'd say go review the steps from the wiki again, to make sure you didn't accidentally overlook something.

    Hopefully you can get your franken pre 2 up & running soon.
  16.    #16  
    i am stuck hopefully rod comes on here and helps out. it shows a doctor under the build folder but i dont know if i should risk it and install it
  17. #17  
    Quote Originally Posted by djfu3l3r View Post
    i am stuck hopefully rod comes on here and helps out. it shows a doctor under the build folder but i dont know if i should risk it and install it
    1. Was your Sprint Pre minus activated on your account BEFORE the swap?

    2. Did you allow the script process to run the Dr. automatically after it completed?

    3. If the answer to question 2 is NO, then what is the name of the Dr. you ran and what directory did you find it in?

    4. Do you have Sprint in the top left and EV in the top right on the activation screen?

    5. Lastly... pick one thread or the other to post your questions in not both.
    Clicking the Thanks button is a great way to say... well THANKS
    Phone Apps: Church Search, Tap for HELP
    TouchPad Apps: Tap for HELP! HD, webOS Meetups
  18. gtn
    gtn is offline
    gtn's Avatar
    5 Posts
    I'm getting the exact same error but I went ahead and installed it on my unlocked (non-verizon) pre 2 w/ sprint. (Installed the jar from the frankenpre directory)

    My profile updates properly and I get all my contacts etc. I can make and receive calls but I can't text.

    There is no sprint logo at the top left but I did get the EV logo at the top right at one point but not it's gone.

    Anyone know why it says permission is denied and about errors 123 and error 2?

    *Update* Google maps does not work, but the gps test works.
    Last edited by gtn; 03/31/2011 at 08:22 PM.
  19. gtn
    gtn is offline
    gtn's Avatar
    5 Posts
    Managed to solve my problem for the error message.

    ***Disable UAC***
    1. restart pc
    2. delete the meta-doctor folder
    3. redo step 1 from meta-doctor wiki
    4. continue step 3 from webos upgrade wiki

    everything will work as stated per the wiki from there. I'm hoping that I can text after this and that gps works.
  20.    #20  
    okay guys thanks for everyone that helped out. i have successfully done it. i dont know what the error was before but i did the same process on my other computer and everything worked like a charm. i am now the proud owner of a sprint pre2

    thanks webos internals i am going to donate by purchasing webosinternals app.

    anyway my pre 2 says it has an update available even tho i am already on 2.1.0 should i download it?
Page 1 of 2 12 LastLast

Posting Permissions