Page 1 of 3 123 LastLast
Results 1 to 20 of 44
  1. sidamos's Avatar
    614 Posts
    Global Posts
    677 Global Posts

    I have a European (GSM) unlocked Pre 2 with webOS 2.0.1.

    Very often it happens, that after leaving WiFi zone (my house), I have 3G and decent signal strength, but internet is not working. Some apps report DNS error, some timeouts.

    Workaround is to enter airplane mode and leave airplane mode. After that, everything is fine.

    I was using the same SIM card before with my Pre Classic with webOS 1.4.5 and never had these issues.

    I guess, it is not a hardware fault, but a bug in webOS 2.x.

    Last edited by sidamos; 12/30/2010 at 12:37 PM.
  2. #2  
    Hi Thomas,

    I have the same problem sometimes and solve this the same way you do. I also think this is a webOS bug.

    Now and then I'm so frustrated and startup my original Pre with 1.4.5 ;-)

    Hope the new update will come soon.
  3. sidamos's Avatar
    614 Posts
    Global Posts
    677 Global Posts
    Thanks for confirming this. So I know, it has no hardware problem.
  4. #4  
    Unfortunately I've had this issue as well. I'll try the Airplane mode trick as I had always just rebooted the phone to fix it :|

    In general I noticed I had issues with my EDGE connection (on T-Mobile USA) dying more often when I am trying to fiddle with my GPS (turn it on/off). Another thing is I think my e-mail was actually still syncing but all other internet connectivity was dead.

    As I said before webOS 2.0 is my first webOS experience and I absolutely LOVE it but it sure is buggy for me all across the board!
  5. sidamos's Avatar
    614 Posts
    Global Posts
    677 Global Posts
    Since this was working OK for me in 1.4.5, I hope they will fix this soon in 2.x.

    Other than that, webOS 2.0 runs pretty well for a .0 release.
  6. #6  
    I have the same problem with an EU Palm Pre 2 (webOS 2.0.1) on Rogers network in Canada (using GPRS / EDGE). The problem manifests itself occasionally when: a) I switch from WiFi to broadband, b) I temporarily lose broadband connection (entering-exiting an elevator) or c) a call comes in.

    I would report it to Palm, but I'm not aware of any bug reporting mechanism they have.
  7. sidamos's Avatar
    614 Posts
    Global Posts
    677 Global Posts
    They have a feedback page but nobody knows what they do with what they get there:

    So, I have posted this in the Palm support forum and here, because I know that at least one Palm employee is reading here.

    With novaterm from the SDK, I have now recorded the output of "ifconfig" and "iptables -L" for these 2 cases:
    - WiFi connected
    - 3G working

    Whenever the problem happens again I hope I can get this info too and maybe it is different and it helps Palm to identify the problem.
  8. nyallj's Avatar
    408 Posts
    Global Posts
    717 Global Posts
    I thought I would ask here, if you don't mind helping please. In Guyana, where I live, we get something like 2G, or Edge internet. But when entering the WAP settings, that is, APN, username, password, a proxy must be set up (in the Treo 650 and Pro that I have, I can do this from the browser).
    I noticed in some earlier posts about the Pre and Pre Plus problems setting up a proxy. Does the Pre2 make allowance for this please?
    Thank you.
  9. #9  
    If you mean "does the Pre2 allow the manual setting of APN, username and password?", then the answer is Yes. If you were looking to manually configure proxy settings, I'm not seeing it in the Network settings. What is this proxy configuration for)? (ie. what is it proxying?)
  10. nyallj's Avatar
    408 Posts
    Global Posts
    717 Global Posts
    Thanks for the reply...
    For detailed info check: Proxy server - Wikipedia, the free encyclopedia
    Basically though it is an interface between computers (in this case phones) and the internet. On some network setups, it is a restrictive device perhaps limiting things like speed, or content access, or both.
    Basically, without this proxy setting, internet cannot be accessed. On my Treo browsers, I can enter the proxy ID in the settings for the browser, does the Pre2 browser allow this (since you say there's nothing for it in the Network settings)?
  11. #11  
    I can confirm the same type of problem on my P102UNA unlocked on AT&T. It not only happens when leaving a wifi network, but also randomly while i am on 3G.

    Airplane mode sometimes works, a reboot always works. but is frustrating.

    Also I noticed that the Pandora music app does not like to resume properly after taking a phone call.
  12. #12  
    I experienced some of this with the Pre 2 on T-mobile. However since I did my Sprint conversion, I don't have this issue at all.
    Clicking the Thanks button is a great way to say... well THANKS
    Phone Apps: Church Search, Tap for HELP
    TouchPad Apps: Tap for HELP! HD, webOS Meetups
  13. #13  
    I had this problem a lot with my Pre 2 on AT&T's mMode (blue) network. I migrated a few days ago and it hasn't been a problem since.

    EDIT: It happened again this evening. Not sure when or how as 3G was working fine immediately after leaving the wifi zone I was in but when I went to check my phone later I noticed I hadn't received any emails in some time. I tried to refresh manually but nothing worked. Rebooted and 6 emails came through right away. Definitely a problem!
    Last edited by nkedge; 01/06/2011 at 12:43 AM. Reason: new info
  14. #14  
    I think it has to do with the carriernetworksettings. When you use the manual settings this happens. But when the settings of your carrier are already correct in the Palm database, this issue never occurs.

    I've been trying to edit the carrierdb.json, but the dataconnection part is an encoded string. I haven't been able to find out how to decode it yet.
  15. Andreas's Avatar
    896 Posts
    Global Posts
    941 Global Posts
    Sounds bad if its coded, atleast for me who needs to edit the carriersettings.

    Reported a incorrect carriersetting in novemer-09 and im pretty worried that the error is still there in 2.0.
  16. #16  
    It is! In webOS 1.x I did the editing myself. But now, that option is gone!
  17. #17  
    Sometimes I have the same problem on pre- and iPhone 3GS.
  18. #18  
    strange... this is a common issue for me with 1.4.5 pre minus gsm german o2 running on german eplus network.

    letting it toggle between wifi and 2g/3g as it wants while roaming between hotspots pretty much all the time it looses correct routing/dns. i expect the tcp/ip layers to ajust like my netbook would when plugging/unplugging network cable and dialing into 2g/3g, but with webos i experience that it "hangs" a lot in these cases.

    so what i do is i go into phone settings and uncheck the "data-usage" option and recheck it immediately (i think there is even a homebrew app called datatoggle that probably would do the same).

    this way i only "reset" these network routing/dns parts and not the whole gsm module.

    i never mess with manual settings as i suspect them to be injected by the gsm network and not by hardcoded luna, but that may be subject to its "unlockedness"
  19. #19  
    Starting to smell like a trend. A couple of similar threads posted in the Pre/GSM categories as well. My AT&T plus has developed a similar issue in the past week or two and I'm not sure what's changed (if anything) on my end. The quickest "fix" I've found so far is Phone Prefs, then toggle DATA USAGE off, then right back on. Something's funky.

  20. #20  
    The problem seems to be getting worse, dropping while on 3G (no roaming from wifi). Airplane mode toggle usually does the trick but seems like the best solution is usually to leave it on EDGE only. Can't really tell if it's the AT&T network or something on the Pre 2. Really becoming an annoyance, though.
Page 1 of 3 123 LastLast

Posting Permissions