Page 1 of 2 12 LastLast
Results 1 to 20 of 22
Like Tree8Likes
  1.    #1  
    Hi all,
    I'm trying to come back to the WebOS fold. To that end, I ordered a palm pixi for sprint on Ebay. Though I've read tutorials on bypassing the palm profile activation screen. I can't get it to work, and am frustratingly stuck. Any suggestions?
    Thanks.
  2. #2  
    Did you get your hands on the devicetool?
    As described at pivotCE:

    https://pivotce.com/2015/06/24/tip-h...ss-activation/

    Your Pixi is likely running webOS 1.x which doesn't use the Phone dialer codes.

    -- Sent from my Palm Pre using Forums
  3.    #3  
    Thanks for the reply. Here's what I've been working off:
    1. Download the activtion bypass tool from http://cdn.downloads.palm.com/sdkdow...devicetool.jar and save it where you like

    2. Get to phone to run in USB mode: depending on the OS this can be a struggle or very easy. The difficult way:
    - take out the battery
    - press the phones 'volume up' button and keep pressing it during the following steps
    - plug in the usb cable while
    - put in the battery and release the 'volume up' button
    If this doesn't work, you're lucky. It'll then work like this:
    - keep the phone as it is, with battery and cover in place and press the 'volume up' button
    - plug in the usb cable and release the volume up button
    The phone is in recovery mode now, you should see the USB logo on the screen

    3. From the command line (in the location where you saved the bypass tool) enter java -jar devicetool.jar

    I've downloaded the tool, and I did manage to get the phone in usb mode (I think). I can't figure out the command line piece of the equation....
  4. #4  
    I'd guess that either the devicetool.jar got renamed during download ala:
    Java -jar devicetool.jar

    ...or you don't have Java on your PC.

    -- Sent from my Palm Pre using Forums
  5. #5  
    Quote Originally Posted by torourke View Post
    3. From the command line (in the location where you saved the bypass tool) enter java -jar devicetool.jar

    I've downloaded the tool, and I did manage to get the phone in usb mode (I think). I can't figure out the command line piece of the equation....
    You need to ensure you are located in the correct directory or include the path to the directory in the command. If on windows, I think you'll see a prompt like C:\ That's your main hard drive. You can then use cd (change directory) to navigate. e.g. "cd program files" gets you into that directory. "dir" lists the contents of the directory. "cd .." (Can't remember about whether or not to include the space) takes you up a level, so from Program files, you go back to C:

    If your tool is just in C:, then the command should work. If you put it in say C:\device-tool-folder\ then you either have to cd to that folder first or from C: type, "\device-tool-folder\java -jar devicetool.jar"

    If you get an error message, posting that here will help us give you the correct advice - along with what exactly you are typing. As already stated, it won't work if java is not installed.
  6.    #6  
    Thanks all. Have Java installed. When I do the command prompt, it says unable to access jarfile devicetool.jar
  7. #7  
    Sounds like you're on Windows and your prompt is in the wrong place or the file is no longer called devicetool.jar...

    If that's the case, you should open a window where you stashed the devicetool download - so you can see the file icon and name. Right-click on the file and choose "Properties" (usually the bottom option in the context menu). Copy the file name from that selectable text box near the top of the file properties dialog.

    Now going back to that window that shows your downloaded devicetool file, if there is any empty space in the window (so that you aren't going to click on a file or folder), hold Shift down and Right-Click and choose "Open Command Window Here".

    That should open a command prompt in the folder where your devicetool is.

    Type:
    Code:
    java -jar
    Note that I typed in a SPACE at the end - after "-jar" above, but the forum code strips it out - There must be a Space after "-jar".

    Now Right-Click in the Command Prompt window and Choose: Paste

    Your Command Prompt should now look like below where "<ActualDeviceToolName>" is what YOUR devicetool file is called.
    Code:
    java -jar <ActualDeviceToolName>
    Hit Enter on your keyboard and it should work...
    (Finger-crossed)
    Preemptive likes this.
  8.    #8  
    Thanks for the help. Followed the directions, but am getting the same message: unable to access jarfile devicetool. Maybe I'll try to delete and download the devicetool again...sort of at a loss. Feels so close to WebOS goodness!
  9. #9  
    The error you're getting would not be issued if the file was bogus or corrupted.
    It means that Windows can't find a file with that name where you are telling it to look. The error would be different if it were finding a bad file.

    The error could be from having spaces in the file name, so if you downloaded "devicetool.jar" and renamed it "My Awesome webOS Device Tool dot jar for bypassing activation.jar" the method I posted would generate the error you're seeing.

    If you have those spaces in your file name just remove them and try again.

    -- Sent from my Palm Pre using Forums
    Preemptive likes this.
  10.    #10  
    The file is simply named 'devicetool'.... I appreciate all the suggestions/assistance!
  11. #11  
    Okay, my bad... I never run Windows with the default Explorer setting: "Hide extensions for known file types" and I incorrectly thought that the properties dialog would show the full name. I just changed the setting on a Windows 7 laptop and sure enough my file "fake-devicetool.txt" shows up as "fake-devicetool" in the File Properties dialog.

    Since you have the command prompt in the folder where the file is, you can get the real name by using the "dir" command. Just type dir and Enter in your command prompt which will give you a list of all the real names of the files and subfolders there. You should see your devicetool file as either "devicetool.jar" or "devicetool.zip" whichever it is, type that after the trailing space past:
    Code:
    java -jar
    Preemptive likes this.
  12.    #12  
    Now it says connection refused....
  13. #13  
    Okay, I know of 2 conditions that will cause that error [EDIT] - Assuming your phone is still in USB Recovery Mode:
    1. novacom is not working
    2. bad usb cable

    To test for #1, type novacom in your command prompt - it should say something like "unable to find device"
    For #2 try to find an original Palm/HP USB cable, or if you don't have one of those, try every micro USB cable you can find...
    Last edited by bbito; 05/13/2017 at 01:44 PM.
    Preemptive likes this.
  14. #14  
    If you get something like "'novacom' is not recognized as an internal or external command..." you should probably kill two birds now and grab WebOS Quick Install (another java program) that you will need later anyway to install Preware. It will install novacom and then after you get past this activation bypass, you'll use it again to install Preware (and maybe other stuff).
    WebOS Quick Install v4.6.0

    download it to the same place you have devicetool.

    In your command prompt type:
    Code:
    java -jar WebOSQuickInstall-4.6.0.jar
    It should install novacom and then complain that you do not have any webOS devices connected. Quit it and then (assuming your phone is connected in USB Recovery Mode), try the devicetool again:
    Preemptive likes this.
  15.    #15  
    Bless this forum! Profile is bypassed. Now off to the sprint store for activation. That part better work
  16. #16  
    Hey @torourke, Could you write a little about how you made it through? Giving back to the forum in this way helps others.
    Preemptive likes this.
  17.    #17  
    It was all you! I installed Quick install, switched usb cables, and tried the java -jar command again and it worked. Not sure exactly what did the trick.
    bbito likes this.
  18. #18  
    Hats off to bbito for going above and beyond!
  19. #19  
    Right back at ya Preemptive, thank you for the tons of work you do for this community!

    -- Sent from my Palm Pre using Forums
  20.    #20  
    Thanks to all who chimed in, especially bbito! Much appreciated. Happy to be back in the fold.
Page 1 of 2 12 LastLast

Similar Threads

  1. Stopwatch app for veer?
    By Alibamboo in forum HP Veer
    Replies: 2
    Last Post: 05/09/2017, 01:22 AM
  2. Replies: 0
    Last Post: 05/08/2017, 11:26 PM
  3. Is the kindle app syncing for you?
    By mazzinia in forum HP TouchPad
    Replies: 15
    Last Post: 05/08/2017, 11:28 AM
  4. pixi flashlight???
    By koteh in forum Palm Pixi and Pixi Plus
    Replies: 0
    Last Post: 04/25/2017, 10:20 AM

Posting Permissions