Results 1 to 9 of 9
  1. fmhcom's Avatar
    32 Posts
    Global Posts
    74 Global Posts

    This Morning I went to the App catalog to purchase Preware because of all the nice things I have read about it. The App is in the App Catalog but when I select to purchase the App for $.99 nothing happens. I took the battery out of the phone and rebooted the phone thinking maybe something on the phone was tangled. After rebooting the same thing. I tried downloading a Free App and it worked. I tried a random paid App and same thing it hung.

    I then go into the Preferences and Account Settings in the App Catalog and there is no Account Setup. I click on "Add Account" and it asks for the Palm Profile Password. I type in the Password and after about 60 seconds it returns and nothing happens.

    Now is the issue with the phone or the App Catalog? is this the Infamous Certificate Issue causing the problem?

  2. #2  
    I didn't try to buy anything, but it did show my account info (it took a while to populate.. Showed the busy spinner and default empty fields for probably 30 seconds).

    -- Sent from my Palm Pre3 using Forums
    Last edited by Grabber5.0; 12/08/2013 at 01:05 PM.
  3. fmhcom's Avatar
    32 Posts
    Global Posts
    74 Global Posts
    The problem Pixi is the Unlocked GSM unit. The Verizon unit shows my account as soon as I click on Account Settings. That's why I am wondering if something on the phone is off.

    The Verizon Pixi I did the Certificate Voodoo on but not the GSM Pixi.
  4. #4  
    If you haven't installed the cert, you will definitely not be able to download apps. Given the important nature of purchasing, I would hope it would affect that too. Definitely change the date and download the app catalog update app.

    Regarding the app you were trying to purchase - that is the Preware Documentation app - very good info if you have not ever installed any homebrew stuff, but Preware itself is not in the app catalog. The app will explain how to get it, or you can find it in the Preware thread on here.
    Last edited by Grabber5.0; 12/08/2013 at 01:10 PM.
  5. fmhcom's Avatar
    32 Posts
    Global Posts
    74 Global Posts
    Well funny thing is I can install all the Free Apps I want. Just not Purchase any.
  6. #6  
    I actually tried to purchase an app tonight on my Pre3. Didn't work... I picked up my TouchPad and tried it there without any problems. Can anyone else confirm issues with purchasing apps on their webOS phone?
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  7. #7  
    Was your Pre3 in flight mode? Or did you try to toggle flight mode / reboot?

    Apparently flight mode needs to be switched of in order to purchase apps on the phones. You don't need to have a valid SIM or anything, but flight mode needs to be off, i.e. radio part switched on.

    Even with the cellular radio working as expected, I sometimes had the issue that the phone could not purchase apps. Sometimes toggling flight mode helped. Sometimes only a reboot.
    Last edited by Garfonso; 12/10/2013 at 02:13 AM.
  8. fmhcom's Avatar
    32 Posts
    Global Posts
    74 Global Posts
    In my case I was connected to T-Mobile and WiFi at the time of attempting to purchase from the App Catalog.
  9. #9  
    I decided to purchase an app to test this. Purchase worked first time, but download failed the first try. I tapped try again and it succeeded on the second download attempt.

    -- Sent from my Palm Pre3 using Forums

Similar Threads

  1. How to fix App Catalog/App errors related to Certificate expiration
    By Alan Morford in forum webOS Tips, Info & Resources
    Replies: 14
    Last Post: 12/30/2014, 09:27 AM
  2. App Catalog Fix (Says App Updates but no App to Update)
    By demetry14 in forum webOS Apps & Games
    Replies: 97
    Last Post: 10/21/2010, 10:56 PM
  3. Replies: 8
    Last Post: 05/03/2010, 06:07 PM
  4. Future of App Catalog? App Catalog vs. App Store?
    By ostauffer in forum webOS Discussion Lounge
    Replies: 14
    Last Post: 12/04/2009, 11:38 AM
  5. POLL: Palm App catalog vs Homebrew Catalog -
    By Bishounen in forum webOS Apps & Games
    Replies: 16
    Last Post: 09/22/2009, 11:35 AM

Posting Permissions