Results 1 to 14 of 14
  1. mntbighker's Avatar
    2 Posts
    Global Posts
    3 Global Posts
    I got a Transcend 150x 2GB SD card from NewEgg after reading customer reviews about the Treo650. If I insert the card the phone will read/write but refuses to reformat it. My Mac can mount and read/write the card via my Kensington USB reader. If I reformat the card with my Mac the phone still appears to read/write the card but still refuses to reformat or rename the card. If I reformat FAT with my Windoze laptop via my Sandisk PC Card adapter the Mac refuses to mount/read the card and the phone will still read/write but refuses to reformat it. Although it will rename the card and wreck the format on the first attempt. Card Info shows the card as:

    Secure Digital Card
    Device Id: SDC_1600469D100807

    I hope a firmware update eventually resolves this or at least some better information surfaces.
  2. #2  
    I just ordered one of these.

    Why do you keep trying to reformat it?

    I figure I will leave it as-is. Or format it once time, if needed using my PC, then leave it alone.
  3. mntbighker's Avatar
    2 Posts
    Global Posts
    3 Global Posts
    I am bothered by the fact that the card I use in my phone cannot be formatted by the phone. Also, supposedly the Treo650 wants it formatted FAT, not FAT32. Many 2 GB card buyers here complain they can't use the card unless they format it first. I was being thorough.

    I would like to identify what brands of 2 GB cards can be formatted by the Treo650.

    Today at work I received another Transcend 2 GB card for a customer's Treo650. I had as much, if not more problem with formatting the card. It refused to mount on my Mac or a Dell laptop. I have been using the same Kensington multi-format USB card reader for everything but my Dell at home where I was able to mount it with my PC Card SD adapter. I finally brought the card over to where I knew we had a Sandisk multi-format USB reader. This worked flawlessly on both the Mac it was attached to and the PC next to it. The Treo probably still can't format the card even now that it's FAT format but at least I know it was my card reader causing all the other issues... sheeesh!!! I wish my Powerbook had a card slot so I didn't need the USB reader, but then again the SD adapter also didn't work all that well. The Sandisk reader worked best of all of them. I'm sure glad USB is so "universal plug&play"
    Last edited by mntbighker; 10/28/2005 at 01:50 AM. Reason: Addendum
  4. #4  
    I just got my card. Seems to work fine in my Treo 650. I re-formatted in my Lexar SD Card reader, just in case.

    I get VFS mark of 673.

    My old Lexar 32x gets a VFS mark of 466.
  5. #5  
    Update: Actually, in my Lexar card reader, only 1GB of this card is formatted. I had to use a built-in card reader on my desktop machine to format it.
  6. #6  
    How did it work out of the box (before you even tried to format it)?

    I've had great luck with Transcend flash memory, but have heard about issues with many 2Gb cards so I'm somewhat reluctant this time around.
  7. #7  
    I ordered my Transcend 2gb before these posts went up... finally got around to trying it so I could compare my experience with others so far.

    1. out of the box and into the 650, it detected the card fine with the entire formatted capacity. Copied varies files to and from the card with no issues so far.

    2. after tests for #1, tried to format the sd on the 650, no go.

    3. ejected the card and stuck it in a pcmcia sd card reader for my winxp notebook. I was able to copy files to and from the sd with no issues so far.

    4. put the card into some usb sd card reader I had laying around and plugged it into a winxp desktop. I was able to copy files to and from the sd with no issues so far.

    I did not try to format the card with the pcmcia or usb reader since it was already readable out of the box... may try formatting it later to see what happens.
  8. eKeith's Avatar
    759 Posts
    Global Posts
    781 Global Posts

    Thanks for posting your "Out of Box" results. Now I've got that card on my list...
    Current Phones: Unlocked AT&T Pre3; Samsung Galaxy Nexus i9250; HTC Desire A8181
    Current Tablets: Lenovo ThinkPad Tablet 183825U; HP TouchPad 32GB w/ACL
    Previous Devices: Unlocked UK Pre3; HTC Touch Diamond; Palm Unlocked GSM Treo 680; PalmOne Unlocked GSM 650; Palm Tungsten T3 w/PalmOne WiFi Card, PowerToGo and ASUS WL-330g; 3Com Palm III; Sony Clie N760C
  9. #9  

    By any chance did you try it with Card Export II?
  10. #10  
    I've tried it with Card Export 2. Seems to work fine.
  11. #11  
    Great. Thanks again.
  12. #12  
    I bought this card and had a lot of issues with it. First it seemed to be recognized fine, then wanted to be reformatted every time it was inserted.

    Put it in my wife's Canon SD450 (Digital Camera) and it works fine. Looks like I'll be looking for a different brand.
  13. #13  
    My card still seems to be working fine. I did format it originally when I got it. Not sure if this makes it work better.

    I generally leave this card in my treo 650 all the time.
  14. #14  
    I never formatted mine. Used the stock formatting. Mine is used constantly (reading AND writing) with no issues so far.

Posting Permissions