Results 1 to 8 of 8
  1.    #1  
    Anyone get this working?

    I have FILEPC2PDA set to bluetooth and an incoming port of 4 on my PC (hotsync is not running) and I set PFB to use COM4.

    I can hotsync over bluetooth just fine, just can't get this progarm to work.

    When I run the FILEPC2PDA, I get the bluetooth on my TREO 650 saying "Connecting..." (via bluetooth) and then the error "Could not open com port!" I don't even get to the part where I run PFB.
  2. tdo
    tdo is offline
    tdo's Avatar
    11 Posts
    Here is my experience:

    - I once used filepc2pda to transfer files to a PC over a bluetooth virtual com port. Worked as expected: connection using bluetooth in filepc2pda, select the computer, connect, ready!

    - However before and after this lucky instance, I always get the error "cannot open com port!" in filepc2pda.

    Note that I didn't do anything special to make it work. It just happened to work once. Tried rebooting the Treo 650, the laptop, but no way.

    1) It IS possible to get filepc2pda working over bluetooth virtual com port.
    2) SOMETHING makes that it does not connect.

    1) Is the problem from filepc2pda (e.g. timeout too short before throwing the error)?
    1.1) Do we have another PALM program that simpy opens a connection to a com port and sends data, in order to test whether the problem comes from filepc2pda?

    2) Is it a problem from the Treo bluetooth stack: i.e. cannot establish this connection
    2.1) Is it some preferences that are saved and make that somehow it does not connect? If so can we delete those?

    3) Is it a problem from the PC Bluetooth adapter (internal or external) or drivers?
    3.1) Could somebody who has this problem try with another bluetooth dongle to check whether the problem disappears?

    If I was good at Palm OS programming I would quickly write a small program to open a virtual serial port on and see what happens. I've the SDK, but not really the time to go into that :-(

  3. tdo
    tdo is offline
    tdo's Avatar
    11 Posts
    maybe the working is not correct:
    1) It IS possible to get filepc2pda working over bluetooth virtual com port (got files transferred okay).
    2) SOMETHING makes that _sometimes_ (or most of the times) it does not connect.
  4. #4  
    Hmmm... it would be awesome if this could work consistantly. It would be a great freeware alternative to bluetooth commander...
    aka Gfunkmagic

    Current device: Palm Pre
    Device graveyard: Palm Vx, Cassiopeia E100, LG Phenom HPC, Palm M515, Treo 300, Treo 600, Treo 650, Treo 700p, Axim X50v, Treo 800w

    Please don't PM me about my avatar. For more info go here.

    Restore your Pre to factory settings using webos doctor and follow these instructions
  5. #5  
    It works fine for me.
    PC: Set port to BT_SerialPort (virtual port) and 115200
    PDA: Port speed=Bluetooth
    Make sure hotsync.exe is not running (that BT serial port).
    Start on PDA. PC should note PDA connection.
    Start on PC.
  6. tdo
    tdo is offline
    tdo's Avatar
    11 Posts
    The symptom I have when I start filepc2pda and select my PC: the PC notes the PDA connection (the virtual com port icon of the widcomm bt driver becomes green), then it asks for the pairing (if it has not been paired before), and afterwards it PC and PDA disconnect with the "Could not open com port!" error.

    A question for JEMShoe: how many bt virtual com ports do you have in the device manager?
  7. #7  
    I get a similar error-- once I hit Connect on the T650, it immediately searches for all devices. When I tap on the computer icon, I get a port not found error.
  8. tdo
    tdo is offline
    tdo's Avatar
    11 Posts
    I wonder if the problem is not caused by having several virtual serial ports on the PC. There's no way to select which of the virtual ports to connect to, so maybe it tries to connect to one (i.e. the "first" one in some virtual port list), which might not necessarily be the "correct" one.

    I still don't know why I get 4 virtual serial ports on my laptop. I can delete them but windows reinstalls them when I reactivate the internal BT dongle. And I don't know to which of these serial port FILEPC2PDA connects.

    I'm playing a bit with the SDK of Palm these days. I'll see if I can make a connection to a serial port over bluetooth to check whether this works or gives the same error.

    Does somebody know whether we have the source code of this FILEPC2PDA program? Maybe it's just a simple small bug to squash and all of us will be very happy then!!


Posting Permissions