Results 1 to 3 of 3
  1.    #1  
    Has anyone had this issue? My unlocked Treo650 will not turn on or work unless it is plugged into the charger. I'm assuming it's a bad battery, and I'm hoping it's not a corrupted Treo.

    Prior to this, the Treo worked for a good four months before going into the endless loop from hell. Then when I tried doing all the resets (including a hard reset) and it kept looping. At the end of each loop there was an audible crackling sound.

    Now, when I unplug the Treo from the charger the screen kind of fades until it goes black (in a second or two) and won't turn back on unless I plug it back into the charger.

    Any info would help.
  2. MMT
    MMT is offline
    MMT's Avatar
    84 Posts
    Have you tried an in-cradle reset? This is supposed to reset the power management/charging system. I know you said you tried all the resets, but just in case you missed this one or in case it might still help...

    More info here (sorry for the long url):,Kb=PalmSupportKB,ts=Palm_External2001,case=obj(887)#incradle
  3. #3  
    There is also a zero out reset that takes it back to factory specs....this worked for me when I had this problem several months ago. Turned out to be a buggy 3rd party program.

Posting Permissions