Results 1 to 8 of 8
  1.    #1  
    I'm having a heck of a time getting a Cingular Treo 650 to work on T-Mobile. I have received the unlock code from Cingular and reverified that the code is correct three times. Every time I type it in it says Sim Unlocked but when I put in another SIM card, I get and "Invalid SIM" message.

    I have gotten two replacement phones from Cingular and unlocked them with the same results. The phone I have now is brand new and I followed a long procedure to flash it to the unlocked GSM unbranded firmare (v. 1.13 ROW).
    This should make the phone exactly like an unlocked GSM phone but I still get the SIM error. My friend has an unlocked version of the Treo 650 and it works fine with T-Mobile but his sim won't work in mine. I've tried several different active T-Mobile Sims and they all don't work.

    What am I missing here? Is there something else that could be keeping me from unlocking the phone?

    It's interesting to note that the phone only says SIM Unlocked if I have the Cingular SIM in the Treo and the phone is on. If I have a T-Mobile sim in place then it says Sim NOT unlocked.

    I have verified that I do have the 8 digit Subsidy unlock code and this is what I type to unlock: *#*#91512905#DIAL

    Please Help.


  2. holmes4's Avatar
    982 Posts
    Global Posts
    984 Global Posts
    The "SIM Unlocked" message is given whether or not you enter a valid code. The ONLY way to test if it is really unlocked is to try a different carrier SIM. And as you've discovered, the process requires that the locked carrier SIM be in place.

    All I can think of is that they gave you the wrong unlock code. Call back and try again.
  3. deanfx's Avatar
    288 Posts
    Global Posts
    413 Global Posts
    Did you give Cingular your IMEI number or did they tell you they already had it? The reason I ask is because they are prolly using the wrong number.
  4.    #4  
    They did ask for the IMEI number each time and I've reverified it with other reps too. Each time they give me the same unlock code that is supposedly generated from my IMEI. I can only assume that now Cingular is simply not giving out Subsidy unlock codes anymore. I'd be happier if they just came out and said they were not going to let me unlock so I'd save myself a lot of time and trouble. This has been really frustrating. I think I might try an unlock service unless anyone has a better suggestion.
  5. drensin's Avatar
    39 Posts
    Global Posts
    41 Global Posts
    you probably got the sim unlock code, which is not the same as the subsidy
    unlock code. there are plenty of threads here with that info ... check around.
  6. holmes4's Avatar
    982 Posts
    Global Posts
    984 Global Posts
    Well, no, not with an 8-digit code. That is a subsidy unlock.
  7.    #7  
    Yeah, I verified with each rep that they were giving me the Subsidy unlock code.
    I can't figure out what is wrong.
  8. holmes4's Avatar
    982 Posts
    Global Posts
    984 Global Posts
    Did you do it while standing on one leg and cackling like a chicken?

Posting Permissions