Results 1 to 9 of 9
  1.    #1  
    I do not know what happened, but I can not use any of the buttons on my 650. The screen works and I can tap on it, but I cannot use the buttons.

    I tried a soft reset but that did not work and I cannot do a system or a hard reset because the up button and power button do not work.

    Anyone have any ideas?
  2. #2  
    Had/have the same problem. For me, it was a stuck "shift" button. It was causing all my other buttons not to work. I still have the issue from time to time and am getting ready to take my 650 in for service this week. Here's to crossing my fingers.
  3. #3  
    hey taharka.. what carrier are you with?? im with TMO using an unlocked CING treo.. and my button is stuck.. what do you recommend trying??
  4. #4  
    Have you tried removing and reinstalling the battery? This worked for me when the screen would go blank after a few hours of none use. In the end I had to send it back to Palm. They eventually sent a replacement 7 weeks and 8-10 phone calls later!
  5. #5  
    I've got Sprint. Took the phone in and they replaced the keypad. No problems since then.
  6. #6  
    damn what should i do if i have tmobile and its a cing fone?? who should i take it to?

    i just got my vaja case in today too!!! SON OF AHhh
  7. #7  
    There are only two options for a non-functional or partially non-functional keyboard. Either a new keyboard or a new Treo.
    I had a sticky L key back in the spring and it made my Treo almost unusable. It was so bad that I exchanged it on my CompUSA warranty within 24 hours and I drove 60 miles to get to the store to do it.
    Prior to exchanging it, I tried gently lifting on the edge of the key using a utility knife blade numerours times and it didn't help. The depress feeling was not there on the L key. Very noticable difference between it and all the other keys.
  8. #8  
    Had this problem was a stuck Alt Key. Took it to Sprint Store, they ran a diagnostic and then ordered me a new (refurbished) 650. No questions asked. So far, no problems with the second one. Only thing I can think of is that I sometimes threw it in my back pocket and then sat down. Perhaps that is what caused the stuck key (and no, I'm not that heavy).
  9. #9  
    yeah i think that was it.. the back pocket.. well i started using the treo again yesterday and it hasnt been detonating yet.. but the button is still dead for sure.. good thing i dont use that SHIFT.. well my sticky situation is.. i bought the fone as unlocked cingular from a tmo dealer.. so ill have to see what i can do. aahh

Posting Permissions