Results 1 to 3 of 3
  1.    #1  
    I see plenty of discussion about getting the Treo 650 to run a PPP connection over Bluetooth for a PC running Linux. I might muck with it if/when I get a Bluetooth dongle for my notebook (it doesn't have Bluetooth built-in).

    That leaves me with a shiny new Treo 650 (on Cingular), a notebook running Linux (syncing works fine, btw), and a spiffy aftermarket retractible sync-and-charge cable to connect the two.

    My old Treo 300 worked fine with WirelessModem on Linux -- I could PPP out just fine with it. When I put the newest version of WirelessModem on the 650, I can switch it to "on" just fine. /dev/tts/USB0 and /dev/tts/USB1 appear as they should. The moment pppd starts talking to it over USB1, though, the Treo 650 resets (soft). So no PPP love for me

    PdaNET only appears to work on Windows (it doesn't present a standard modem as far as I can tell -- it uses some hook on Windows to convince it there's a modem attached). I found another program (also called Wireless Modem ... ugh) that was open-source, and does exactly the same thing as the other one. Soft reset as soon as pppd starts trying to talk to it.

    I'd love to figure this last detail out. It's great to be able to connect to the internet with the 650 over the USB charge cable, since it keeps the phone's battery charged while it runs and the cable is just so TINY when not in use (far superior to the wall wart the phone comes with), but it only works in Windows, which I run maybe once a month. All my work is normally done in Linux.

    Any ideas? Can the 650 just do DUN over USB on its own without a helper app? Am I just hosed?

  2. plaut's Avatar
    110 Posts
    Global Posts
    123 Global Posts
    I quickly tried WirelessModem (1.1.2) under FC4 with the same result. I have bluetooth on my laptop so I haven't needed to sort this out. I'll let you know if I come up with anything....
    Palm Vx -> Kyocera 6035 -> Kyocera 7135 -> Treo 650 -> Treo 755p
  3. Hargoth's Avatar
    50 Posts
    Global Posts
    61 Global Posts
    I would also be interested.

    I bought a D-Link DBT-120 for my laptop hoping to get bluetooth working on FC4, but the phone comes up with a connecting 'box' and nothing happens. The logs show that the phone does not repond to AT commands.

    When using this same device on another Windows based laptop to the same Treo 650, it worked just fine and never showed the 'connecting' box on the Treo.

    I used the great tutorial at:

Posting Permissions