Results 1 to 9 of 9
  1.    #1  
    I got a new 1 Gig Lexar SD card today, but my Treo 650 doesn't beep or recognize the card. (This is the first time I've used this card slot). When I put it into the SD reader on my PC, I can read/write to the card just fine, so I know there's nothing wrong with the card. I emailed Treo tech support and they told me to do a soft reset, and when that didn't work they told me to do a hard reset. Well, after losing all the data in my phone, it still doesn't work. Has anyone else experienced this or does anyone have any suggestions? I'd really appreciate it. Thanks,

  2. #2  
    I'd reformat it in a card reader.
  3.    #3  
    Thanks for the suggestion, but I already tried that. I've tried just about everything I can think of and so far tech support is no help. Is it possible that it's a hardware problem? My phone works fine other than that. (I've only had it a few weeks).

    I heard there's another type of card it takes, a "multimedia card", but I'm not sure what that is and can't seem to find one. I was curious if trying a different type of card might help.


  4.    #4  
    Palm tech support is now telling me that only a Palm brand SD card is supported, and this is why I'm having a problem. The one I'm using is a Lexar, which is a pretty standard brand, so I can't imagine that the Treo wouldn't be compatible with it. Are all of you using Palm brand SD cards, or is anyone using Lexar?


  5. #5  
    Reformate in FAT not in FAT32.
  6.    #6  
    That's a good suggestion, but unfortunately I've already tried that. Since you can format right on the phone, it seems like even if it's unformatted it should at least know there's a card in there, even if it can't actually read the card. Mine just acts the same as it does when I put the nonfunctional plastic card in there.. It just has no idea I've stuck a card in there.

    Still wondering if Palm TS is just trying to blow me off or if I really need a Palm SD card..
  7. #7  
    I can solve that question. That is the easier of the ones you have presented. Palm CS is trying to blow you off. I have a reformatted old ATT 32 MB card and it works fine in my Palm Tungsten E. Any standard card should work - I've seen people using SanDisk cards successfully in other T-650 posts on here.

    Try another cheap low MB card in the slot. It will be cheap to test and you can return it if it works.

    Im suspecting you have a bad SD slot though.
  8. #8  
    I agree with stevestr, it looks like it could be your SD slot.

    I 've used ATP and Sandisk cards on mine with no problems and no prior formatting.

    Test it with another SD card and return your Treo for warranty replacement if it cannot read it.
    Visor Deluxe, Prism, Visorphone, Treo 270, Treo 600, Treo 650, and am eagerly waiting for the next generation Treo...but that the iPhone????
  9. #9  
    I have this problem with a 512mb crucial card. it seems to work better if you slot the card in and pull up or push down as you slot the last 1/4 of the card in. it sometimes makes a click noise. I think this may be a hardware issue but i really dont want to be without my treo now it is all set up. if it persists then i may send it back to orange.

Posting Permissions