Results 1 to 13 of 13
  1.    #1  
    I just bought an unlocked (I think) treo 270 but it won't connect to the network with my suncom sim card. First, how can you tell if the phone is locked or unlocked truly, and second anyone got it to work with a treo? The SIM was programmed in a Motorola T721, could that make a difference, getting a new SIM?


  2. #2  
    When you put your Suncom SIM card what do you see on the display?
  3.    #3  
    I see the little dude doing handsprings across the screen with an "OK" button below him. It runs for about 10 minutes then it either locks up or I get some kind of buffer error overflow error. I then have to soft reset it to get it running again. Is is possible that suncom operates on 850mhz and the 270 is only 900mhz or 1900mhz? It works perfectly with either a cingular or tmobile sim in it. The local suncom store was no help at all they won't even try another sim in it, useless.

  4. jpizzaj's Avatar
    120 Posts
    Global Posts
    121 Global Posts
    try asking suncom what their coverage is it is possible they dont operate on 900 or 1900 my local cingular told me that my 180 would still possibly not work all the time because its a dualband when al the new ones are tri or quadband
  5. #5  

    Where did you get your Treo 270? If the seller did not really specify that it was made for the US market, it may not work if you have the non-US version.

    There are two versions made, one for US (900/1900Mhz) and another for Europe and Asia version (900/1800Mhz).

    The other possibility is that you may have a defective radio. If you have friends with TMo or Cingular SIM, see if you can try it with their SIM card. The buffer overflow error does not sound good.
  6.    #6  
    Luckily a lady at work just got a new blackberry 7100 on the suncom network with the data services too, and I popped her sim into the treo and it worked. So I went to the suncom store and asked them for a new sim to try that was version 3.0 like hers (mine was 2.5). I popped it in and it worked. I'm guessing that my sim didn't have the same data that the new one had because it was before they started supporting treo 600's. I haven't tried the iLink service yet because I need an email program first, right? What's a good one (read easy) to use for this model?

  7. #7  

    Thanks for the update. There are lots of email programs available but because of Treo 270's older OS, you may have to be really picky.

    Try the ones with trial period at first so you can see for yourself. Check out the Snappermail software and other third party ones like Chatter who has a good support here under the Developers corner forum. See also the General Software or Communications forum for other software.

    As most users have migrated to Treo 600/650, you may not find the postings applicable for the Treo 270.
  8.    #8  
    Well I've tried snappermail but for some reason comcast closes the connection and I can't download message, although I can send. Chattermail doesn't work on the 270, gonna try agendus mail tonight. Any other ideas?

  9. #9  
    Quote Originally Posted by kfctombraider
    Well I've tried snappermail but for some reason comcast closes the connection and I can't download message, although I can send. Chattermail doesn't work on the 270, gonna try agendus mail tonight. Any other ideas?

    If comcast is your problem, no email client will fix that... Snapper is the only one i can think of...

    Iím a lucky man to count on both hands
    The ones I love..

    Visor Pro -> Visor Edge -> Treo 180 -> Treo 270 -> Treo 600 -> Treo 650 -> T|T2+SE T68i -> Treo 600 -> T-Mobile MDA -> Treo 755p -> Treo 800w -> Treo 755p -> PALM PRE -> Palm Pre 2 -> HP Palm Pre 3

    Twittering about
  10. #10  
    How are you connecting to the internet, i.e. what's your data subscription like?
  11.    #11  
    I'm now wondering if the "host disconnect" issue is with Suncom and not Comcast. Maybe Suncom is closing the port down when it senses data trying to come through the connection. The Blazer web browser doesn't work either, could be the same issue? I'm using GPRS 1.1.1 with the iLink service 5mb per month because that's what suncom told me was all I needed to check email. I might try to add their unlimited plan just to see if that's the issue, but I'm not going to pay $20/month just to check my email a couple times a day, I just don't need it that badly.

  12. #12  
    It could very well be that Suncom is only opens up limited number of ports. Same happens with other providers like T-Mo when you take their lower value data plan.

    I have seen some postings with other users that had success using the lower value data plan. They are using some proxy account. That may open up your information to possible third party that you don't want to but users proclaim success. Search for proxy. I will see if I can give you the key threads as well.

Posting Permissions