First of all I have searched and used this forum to try to get the answers I need. There has been valuable information, Thank You! for the valuable insight I have gained.
Nevertheless, none of it has completely worked.
I have an unlocked GSM Treo 650 with T-Mobile.
I'm using Webdogg's custom ROM #1 with the BT DUN hack. (Thanks Webdogg and shadowmite!:
I cannot get the Dial Up Networking going, even though I have tried all the answers suggested in this forum.
First, I tried it without PDANet. I installed my Motorola bluetooth card and software, and the bluetooth software could do name recognition with the Treo, but could not connect.
1. The bluetooth modem is active on Port 7.
2. I used the extra initialization code "AT+CGDCONT=1, "ip", "" suggested in the DUN users manual. Yes I found the user manual via a previous post. It is at:

No matter what I did, it simply would not connect.

Finally, I broke down and bought PDANet from, based on suggestions from this forum. After fighting with it all night until 4 am this morning, and much of today, I still cannot get a successful connection. I am very close, though. I have finally gotten the computer and the Treo to see each other's names, and to initiate the bonding process. But it still fails when I try to enter the passkey in each device. I enter the exact same passkey, but it still gives the error "Unable to add laptop to your trusted device list."

There must be some final small detail that I am overlooking. I have tried putting *99***1# as the number to dial, but this also does not do the trick.
So.. I ask the Treo sages... What do I try next?

Thanks in advance for your assistance.

The Unit Simulacrum

BTW: I cannot "Setup Devices->Trusted Devices->Add Device" when DUN is already turned on and the Treo headset is already connected. I have to delete the headset as a trusted device, and only then will it initiate the Add Device dialog-- which it fails shortly thereafter when it cann add the laptop as a trusted device. Thanx