Results 1 to 12 of 12
  1.    #1  
    Newbie here...

    My Treo 650 is two months old. No problems until now.

    I noticed the power light of my Treo had turned red, so switched it off, and plugged it in to be charged. Plugged it in and the keyboard lit up, but the screen was blank, and the keyboard light did not turn off. So I tried to turn it on/off again, and now I have what appears to be an irretrievable situation.

    If I plug in the charger now, there is no chime, no charging light, and no response to any keys at all. I've tried a soft, medium, hard and in-cradle reset - nothing happens. I've read that with one of the resets, the Treo can appear "dead" but then wakes up after about ten minutes having completely wiped the data by overwriting everything with 1s and 0s. It hasn't awoken for about an hour.

    Prior to this my Treo had no problems at all, except for this morning when my Treo alarm woke me up, as planned. The sounds that the Treo makes when an SD card is inserted and removed kept on repeating (as if I was inserting then removing the card repeatedly). I removed the SD card, and it continued, so I reinserted the card, and the problem resolved. Didn't think much of it at the time...

    Is there ANYTHING I can try? I have most of my data backed up on my computer, so any sort of resetting is not a problem. Your thoughts would be hugely appreciated.

    Many thanks
  2. #2  
    ehhhhh ---- you DID remove the battery (and replaced it), right?
  3.    #3  
    Ummm, I'm afraid so... Have I committed a fatal crime...? Please tell me this is retrievable. To turn it off I had to remove the battery because none of the buttons were functioning - that's when it went blank. Have I ruined the battery? Or the Treo? Or both?
  4. #4  
    If you purchased it from a Cellular provider or Palm1 I'd contact the place of purchase and see about replacing it as it is undoubtedly under warrantee. If you bought it through the gray market (ebay or a mom and pop cell store) you are probably still covered under the Palm1 warrantee.

    It does sound to me like it's dead. It didn't get wet by any chance, did it? If so let it dry for a while without the battery in it... mebbe it'll spring back to life.
  5.    #5  
    Signs of life!!! But still in a nonfunctional state

    I removed the SD card, blew inside the port, and plugged the power back in without the SD card in. Now the power light is orange, the keyboard is lit, and the screen remains blank. The screen did light up for a little while - the reset power-up screen showed up, but the progress bar only went about half way before the screen turned off again. Still no response from pressing any keys.

    I wonder if blowing into the card port was coincidental - I somehow doubt that this could have stepped back the state of the Treo. But removing the SD card?

    I'm too concerned now either to disconnect the power source, remove the battery again, or reinsert the card for fear of reinstating the previous "dead" state.

    Any suggestions as to what I can do from here?

    In answer to your queries, ronin4740, the Treo hasn't been wet, and the Treo should be under warranty. I bought it from Fortress, a reputable electronics store in Hong Kong, which means that it has a one year warranty in Hong Kong (only). Unfortunately, returning it ain't gonna be easy - I am now in Taiwan!
  6. #6  
    Just a wild last shot. Leave the SD card out, pull the SIM card and leave the slot open. Set a hair drier on low heat and high fan and blow it in the slots for half an hour or so. Then pull your battery cover in preparation, plug in the charger and if you get any light or activity at all try a hard reset. If that doesn't work then probably not much chance of anything else working. You will be left with a trip to HK to swap for a new one. Good luck.
  7.    #7  
    Thanks jgm.

    Tried that, but no luck I'm afraid.

    I thus tried another "last resort". Removed the power cable, removed the battery, reinserted the battery, reset screen showed. Progress meter did not complete, and the Treo returned to a state of: orange power light, blank screen, keyboard light continuously lit, unresponsive to any keys. So I repeated this and tried a hard reset. Same thing occurred, but this time, the Treo returned to a "dead" state, and has remained so.

    I will wait again to see if it miraculously wake up again to the orange light, blank screen, lit keyboard state. If it does, I will try a Zero State reset by removing the battery, pressing all the relevant buttons, inserting the battery, waiting for the reset progress meter to start, and then press the reset button. Hopefully that will cause the Treo to completely rewrite its drive, and perhaps give me a fresh start.

    If that fails, I'm stuck...

    However, as I said in my first post, I'm a Newbie to all this, so please, if there are any ideas which may help from you guys out there, please post on this thread. If this is a hopeless situation, then please let me know, and I will work out how I can get this Treo back to Hong Kong!

    Kind regards,
  8. #8  
    One last idea. Try installing one of the firmware upgrades from the SD card. From what you say it may not get far enough to start the install process but it is worth a try. Oh, and try giving it a few good thumps, within limits of course. Just in case something is loose inside and shorting something out. I suspect you may have done that already though.
  9.    #9  
    Thanks JGM

    But please explain how I can do a firmware upgrade from the SD card. I'm afraid this has lost me a bit...
  10. #10  
    I should have asked of yours is GSM or CDMA. There are unofficial firmware upgrades that have been leaked from PalmOne for the GSM phones. See: There are other threads that go into more detail on actual install methods and tips. You can do a search for them. If you have a CDMA phone you are out or luck at the moment although there is a rumored firmware release for sometime very soon.
  11.    #11  
    Thank you JGM, I would have tried your suggestion, except...

    I can't believe this has happened, my Treo is now working (in a zero reset state)... Here's what I did:

    An hour later, I removed the power cable from the Treo and battery, and unplugged the power cable from the mains. This time I got ready to do a zero state reset, just in case the Treo started the reset progress meter again. With the unplugged power cable attached to my Treo, fingers on power/up/hotsync buttons simultaneously, and with the stylus held between my teeth resting on the reset button, I put the battery back in. The screen lit, started the progress meter, and I pressed the reset button for a zero reset. Then I saw a rainbow screen with boot load v 0.18 showing. It says in the PalmOne website that if you see this after attempting a zero state reset, you've done it incorrectly and suggests trying again. Tried it three more times, no luck, just kept on returning to the rainbow screen. So I then tried a soft reset - nothing. So I tried a warm reset - and everything died. No lights, no action, no nothing.

    After an overnight charge in this state, I tried again with my tactic of interupting the progress meter on the reset screen, if it returned. Sure enough, I removed all power, then plugged in the battery, the screen lit up, progress meter continued, and I did a hard reset... and it worked! For some reason, the reset completed, and I have now got a fresh Treo. It appears that the zero state reset could not complete for some reason, and required a hard reset to finalise?

    Anyways, thanks for all your help everyone. To be honest, I'm gonna exchange my Treo anyways via the warranty when I return to Hong Kong in a few months time. If it's unstable once, and it's in warranty, then I say exchange it whilst you've the chance.

  12. #12  
    Great, glad you got it working again. My motto has always been "plain dumb luck over superior skill anyday".

Posting Permissions