Results 1 to 2 of 2
  1.    #1  
    I just ordered a 3 pack of screen protectors from the Treo Central store and the touch screen on my Treo does not appear to work as it did before. The area above the home button cannot be pressed with my finger or my stylus unless I tap it about 5 times. For those of you that use Snapper, basically the entire Send / Receive button is almost impossible to hit. The area around the New button is fine.

    If I take the screen protector off, this area responds as it should with a tap of my finger or the stylus. I reapplied the first screen protector multiple times and even tried a second one and I am still having these problems. I'd hate to have to use the third one only to find out I am having the same problem.

    Before I got the new screen protectors I had a screen protector on that I also bought from the TC store and it had no problems at all. I know this seems crazy, but anybody have any ideas. I've tried about all I can think of.
  2. #2  
    I know what I am about to say shouldn't make sense since it works ok with one and not the other, but I would try this anyway"
    Make sure there isn't any debris lodged between the screen and the case. I would use the corner of a very thin piece of plastic and pass it along between the case and the screen.
    iPhone 4S
    Former Treo & Storm Owner
    Cigar Lover

Posting Permissions