Results 1 to 20 of 20
  1.    #1  
    I had my GSM Treo 650 exchanged under warranty over another issue. The new Treo freezes when idle for a while, fresh out of the box. I decided to upgrade the firmware (as I had done before), trying 1.15, 1.21, and 1.23, with lots of hard resets in between.

    I have no additional software installed, and the Treo has been given a hard reset with nothing added. Hotsyncing all my old software into the Treo does not solve the problem. I have tried it with the radio on and off, and bluetooth on and off. (Though I have not tried every combination with every firmware version, it is safe to assume that results would be similar. Besides, it should NEVER be freezing while standing by under any simple configuration like this!)

    The device just freezes in 15 minutes or so after being idle. Nothing except popping the battery or using the reset button elicits any sort of response. No amount of button pushing or waiting fixes this situation. Sending text messages to my phone while it is in this state gets no response. Provided the radio is on, LED does continue to blink green, even if the signal is lost. It appears that the device does log on and off the network when signal is gained and lost, however, because I can hear it causing the classic GSM interference.

    I suspect I'm going to have to get them to replace the new Treo. I guess I'm going to call them up tomorrow morning. Man, I'm getting sick of warranty exchanges! Is there anything else I can try? Fresh firmware + hard reset SEEMS to be just about everything. Any thoughts?

    Aside from this, the Treo seems to function perfectly, reliable multihour calls, DUN, etc. Though I should note the battery cover doesn't like to "click" into place very well, it can be made to do this with a hard, rapid push.

    Also, in the future, is this an issue that is caused or fixed by firmware updates? I'm mostly curious as any and all possible causes.

    Thoughts anybody?
  2. agh3's Avatar
    2 Posts
    No solution for you, but firm "me too". We ordered 4 from Cingular Corp Accounts (what a joke!!! but that's another story). The last one to arrive, we put it on the charger overnight cause our rep messed up and couldn't port the # over. In the morning, the charge light was still bright orange/red and no keys would wake it up. Popped the battery and all was well...while I installed the apps for the user. Letting it sit for 15 to 20 mins while I tracked the user down for training, it was locked up again. Green light-a-blinken, but not really alive. No static on the nearby speakers either. This happened 3 more times in the course of 3 hours.

    We called Cingular and they're shipping a replacement.
    Andrew Hargreave
    Locked Cingular Treo 650
  3.    #3  
    Glad to hear I'm not the only one. I'm going to call up Cingular shortly...
  4. #4  
    Palm produced a batch of bad units. I had mine replaced within 14 days of getting it. My unit would lock up due to the dreaded HALRadio error, which is non-fixeable hardware issue. On am on day two with the new unit and all is good. Later.
  5. #5  
    A batch that's an understatement.
  6. noc
    noc is offline
    noc's Avatar
    74 Posts
    thought it was just me. now i have treo #3, replaced for bad speaker on #1 and #2. i did update #2 to 1.23. are you saying the freeze is happening out of the box, so no update to 1.23? I'm trying to isolate. Also, are you saying that P1 has acknowledged this as an issue and said no fix therefore sending you a new one?
  7.    #7  
    I have a new phone shipping to me. Hopefully, this one will be good. I can only imagine how many units PalmOne must be going though. I wonder what repair costs amount to for Treo 650s on the part of PalmOne?
  8. #8  
    I went throught EXACTLY the same thing with a Sprint Treo 650 I got from eBay, and it was brand-new. LUCKILY, the seller was VERY cool about the whole thing and sent me a replacement. The one I have now has been flawless.

    Guess I got one of the bad batch....

  9. #9  
    I am sooooo fed up with Palm & my new TREO 650. I love the phone, but had to goooo through 1. Bad Speaker=Returned. 2.Freezing after charging=Returned. Whats up with the Treo's from palm. I have a GSM unlocked?
  10. #10  
    I had the same thing happen to me too.. Reset with no software on it at all.. it would reset 5-20 mins after turning on the Wireless mode even afer a hard reset!! got a replacement model.. Unlocked GSM on my part. thot it was my sim card. got a new one on a different carrier and it still did the same..
  11. #11  
    Just adding a "me too".

    I had a Sprint unit, brand new, and it would reset all the time. Whether on the phone, browsing the web, in VersaMail. Anything.

    I lost a bunch of phone calls.

    Took it back to Sprint within my 14-day "grace period" or whatever it is and my new unit is running like a charm. But for those first few days I had a sick feeling in my stomach like "what did I get this expensive POS for???".
    PalmIII -> PalmV -> Sprint Treo650 -> Treo755P -> Pre

    "Never underestimate the bandwidth of a station wagon full of tapes hurtling down the highway."

    --Andrew Tanenbaum
  12. #12  
    I had the same problem and tried everything. I found it should be the Phone App or operator related. Finally I found a solution - downgrading CarrierProfiles2.pdb and NetworkProfiles2.pdb files. The version of these files is displayed on the second page of phone info in Phone App (software 1.20 only). Version 255 (the default for this software version) is buggy for me. After a hard reset I just overwritten these two files in the RAM then reseted the device (also taken the battery out for a short time to be sure). From that poin my Treo never frozen this way. I used the second latest version of files but some else could work for others. Hope this helps.
  13. #13  
    Wexx, I am trying to check on your recommendation. But my Phone App Info has only one page.
    Any thoughts?
  14. #14  
    u have to be on the home page of your treo first and then press the drop-down menu and select info.
  15. #15  
    Try this link:

    This guy goes through some troubleshooting tips that are really helpful. I was having the same problem as you - have exchanged my phone twice. I downloaded a scan utility that this guy refers to to id some bad files and so far my phone has stopped the intermittent freezing. Seems like I may have messed something up when I installed the Treo software over the older Palm OS. I should have done some cleaning up prior to the install. If this latest thing doesn't work, I am contemplating a total uninstall, hard reset and reinstall. I only use the Treo for calendar and contacts and phone. Nothing else, so I don't know what the problem is. Oh yeah - I even got a new SIM card, but it still froze. Good luck to all of us in the Treo "ice age" of frozen keys.
  16. #16  
    Sometimes Hard reset is not the exact solution. Try doing Soft reset 3x !!! That works !!! Im working for Earthlink Technical support & we are also Helio's Tech support Team
  17. #17  
    I hate to disappoint you all but I'm on my fifth phone!!! Same problem each time with frozen keys. This latest one lasted six weeks before the keys started freezing. (So I'm curious how your fixes have lasted). Hard reset won't work because you need the center key to complete it and that key is frozen. Any ideas besides a class-action lawsuit? How many hours have we all spent trying to fix this? (A friend says he knows somone on his 13th phone.) This is very frustrating. (BTW, I'm on the Mac using Verizon, who is not much help. They've started shipping my replacements via ground rather than FedEx, probably because I'm no longer NICE.) Would love to have any help!
  18. #18  
    Two phones, both experienced the problem but....

    I believe it has something to do not with the units, but the area. I NEVER freeze when at or around my home location (Long Island) but would regularly freeze when in midtown Manhattan. The odd thing is that I'll go several days with regular freezes at work, then weeks with no freezes.

    Can it be the Treo getting confused with different towers? I haven't changed any software in six months, so I don't believe it has anything to do with what's on my Treo.

    I've tried to look at the DEBUG screen (#*#33284 on Verizon). About the only difference I see is that when it's in its "freezing mode" the FCH Walsh Code is 001, followed by a lot of zeroes. When it's working well, I've got all field populated with something.
    Palm Vx => M505 => M515 => T =>T3 =>T5 =>Treo 650 => Treo 700P (Verizon)
  19. #19  
    The solution to my unit was replacing network DB and carrier DB with their older version. It is stated elsewhere on this forum.
  20. #20  
    Greetings all~ after a couple days of searching for potential solutions, without posting a new thread, I think i found the thread i am looking for. I have an unlocked 650 GMS, have recently moved to Cambodia, and the phone was in light use for about a month during the transition.

    I had been using a local SIM for a week or so and things were working fine, then a few days ago, it started freezing. When i soft reset, it works fine until i power on the phone connection, then it doesnt outright freeze, but sort of long delay stalls, cant really do anything functional, and cant receive (or dial) calls. Nothing added recently.

    Anyway, tried some of the tricks people have suggested (turn off BT, take out memory card, do not allow local time). Any other suggestions before I throw in the towel? By the way, i've had it for about 1 and 1/4 year, and has mostly worked great (except having to learn that the TMobile Sim doesnt fit, and having to do the stick-um paper solution).

    Thanks for any help!

Posting Permissions