Results 1 to 17 of 17
  1.    #1  
    I upgraded my dual-G5 to Tiger recently and now I'm having problems trying to get my Treo 650 working with Bluetooth. The major issues:

    • When I try to set up the Treo in Bluetooth Preferences on the Mac, it always attempts to determine what services the phone supports and reports that no services were found on the device. Then it greys out the options to sync, browse and use the phone for DUN.
    • In spite of that, Bluetooth hotsync does work intermittently. Best results come when I have just sat down and logged into the machine. Even after a successful sync, setup in the Bluetooth Preferences can't find any supported services on the Treo.

    I'm using an after-market Belkin USB Bluetooth adapter that's plugged into the open USB port on my Apple keyboard. The Belkin adapter claims to support Mac OS X and all of the relevant Bluetooth profiles.

    Is anyone else having this problem? I added the Bluetooth to the machine after upgrading to Tiger, so I have no way of knowing whether it would have worked before.
  2. #2  
    I set my Bluetooth sync up for the first time last night. It wasn't totally straightforward, and I messed with several things while doing it so I'm not sure what finally worked. Here's what I think worked on mine:

    1. Open Hotsync Manager
    2. Click Connection Settings tab
    3. Make sure Bluetooth sync is selected and the default Serial connection is selected
    4. Make sure Bluetooth is on on the Mac and set to Discoverable
    5. Open Hotsync on the Treo 650 device itself
    6. Not sure what I did next, but I think I changed Cradle/Cable to Bluetooth under the Hotsync button and then it found my Mac. Then I did a Hotsync by pressing that Hotsync button on the device
  3.    #3  
    Yeah, I can usually get mine to do that, as well. I'm wondering whether anyone has successfully gotten the Bluetooth Setup Assistant in Tiger to find the services on the Treo under Tiger. If so, what hardware are you using and what did you do different from me?
  4. #4  
    Mine only shows OBEX Object Push. What else do you want to do with 650/Mac besides sync? I can't think of anything else I'd need to do. Yeah, it's neat having the phone SMS or dial from Address Book, but I got rid of text messaging on my phone plan.
  5. #5  
    My Sony Ericsson T610 worked fine with Mac. I am guessing it's a Palm problem. GO FIGURE.
  6. #6  
    interesting. i am using 10.3.9 with a D-link USB BT adapter (this is the same exact hardware in the powerbooks etc.).

    i can pair the treo 650 (sprint) with the mac, but then the mac says there are no services available on the treo. i thought perhaps i was missing some software on the treo; i never installed the palm software because shortly after pairing the device, i tried sending files to the treo with the Bluetooth File Exchange program and it worked. i was able to send midi files to the treo, send Address Book entries to the treo, send pictures back and forth, and even send apps to the treo all using BTFEx...

    unfortunately iCal events didnt work right; they were discarded by the treo and when i sent treo events to the mac, iCal didnt know what to do with them.

    so am i missing something here? will i get any sort of iSync support if i install the Palm software?
  7.    #7  
    The whole thing is just bizarre. Mac OS X never reports any services being available, but things seem to just work. Except when they don't.
  8. #8  
    Haven't had a problem syncing with Tiger and Missing Sync using iSync. Make sure if you use iSync you enable Palm OS syncing under devices. I love being able to sync via bluetooth!
  9. #9  
    Using a Verizon 650 and 1.5 GHz AIBook with 10.4.1. Mine is working. Initially it was a bunch of hit and miss. I wasn't really sure what exactly made it work, but it did.

    Then, I had the misfortune of having to completely re-do everything from scratch after Verizon's "Wireless Sync" hosed my Palm (it's really aggressive and will take over your calendar and contacts making it impossible to sync your Mac). So, having had to set it up twice, I recommend this...

    (1) make sure you are not using vzw's wireless stink;
    (2) Go into iSync > Devices > and click on "Enable Palm OS Synching..."
    (3) now...assuming you have already paired your devices and set up your phone, you should be able to initiate the sync from your phone (i.e, click on your palm's hotsync app). If not, run Applications > Utilities > Bluetooth Setup Assistant.

    p.s. I don't recall ever actually "seeing" the services being available on my AIBook with the 650 (and I'm afraid to mess with it to see). However, I do remember seeing them dimmmed out tho when I went to the Verizon store and tried to sync a Moto flip phone to my computer. On your Treo it should just work after enabling OS Syncing and running the BT Setup Assistant. Lemme know...
  10. #10  
    Which serial device do you choose? I think I have everything else set up right, except the configuration of the virtual serial port. It lists a whole bunch of modems that I don't have and don't understand why I'd need. I have a Dlink bluetooth adapter, but I just can't get it to hotsync. My phone sees the computer and vice-versa, but it always says that the port is in use by another application. Anyone having this problem too?
  11. #11  
    should it list the ability to do Bluetooth DUN and what not in the bluetooth setup assistant or somewhere else? I'm also using Tiger.
  12. #12  
    Was this problem ever resolved? I just bought the d-link bluetooth USB adapter. I've tried everthing listed on this thread and others. I'm running 10.4.5 iMac g3 & Sprint Treo 650. I can't get the treo to sync via bluetooth.
    I'm using the Palm software & iSync. I can transfer files fine, so they're paired properly. Serial Port in Bluetooth System Prefs is checked. Both items are discoverable, hotsync is enabled. I've been messin around w/ it for over 2 hrs now. Any help would be apprecaited!
    Last edited by depthoffield; 03/23/2006 at 11:32 PM.
    Treo 650/Sprint PCS
    Marlton, NJ
  13. #13  
    Me too - no capabilities showed up after pairing (even with DUN checked), so I installed the Palm Desktop software, and now stuff shows up after pairing. This could have been a fluke, since I haven't tried this again.

  14. #14  
    Quote Originally Posted by phandel
    Me too - no capabilities showed up after pairing (even with DUN checked), so I installed the Palm Desktop software, and now stuff shows up after pairing.
    I've had it installed the whole time. Guess I'll call palm tomorrow. Does Missing Sync work anybetter w/ bluetooth transmission? Thanks
    Treo 650/Sprint PCS
    Marlton, NJ
  15. #15  
    Ya know what, I'm totally wrong ... I just clean re-installed Mac OS X and didn't install Palm Desktop, and the DUN was found right away in the Bluetooth Setup Assistant. Apologies for the noise.

  16. tallboarder's Avatar
    2 Posts
    Global Posts
    8 Global Posts
    I found the following thread at and it helped me to get my Treo 650 DUN working with Mac OS X 10.4.6.

    Apparently after upgrading to Mac OS X 10.4.6 I lost the BlueTooth's ability to
    see services on Treo 650. I found this link and it says the Bluetooth Setup
    Assistant 1.7.x was at fault. Go to the following link and search for 'DUN':

    I followed the suggestion by copying Bluetooth Setup Assistant (version 1.6) from another G4 laptop and it worked!

  17. #17  
    Quote Originally Posted by depthoffield
    I'm running 10.4.5 iMac g3 & Sprint Treo 650.
    download 10.4.6 it fixes all that hotsync and bluetooth stuff!

Posting Permissions