Results 1 to 2 of 2
  1.    #1  
    Hi there,

    I have been a proud owner of an unlocked, unbranded Treo 650 for a week now.

    HOWEVER, I am quite puzzled at the following situation:

    1. When I got the phone I also got Sony Erricson HBH-602 BT headset; it worked without any problems for less than 6 hours (non-countinous use). As soon as I upgraded Treo's firmware to 1.23 the BT headset stopped working. Treo 650 discovers it fine when I initiate the BT headset side button, logs in as trusted device then it won't establish connection at all.

    2. Okay, I went to the extent of purchasing a second BT headset HBH-600 this time and it worked just fine for a total of three-four days. Now it acts like the first BT headset HBH-602: my Treo 650 only sees it when I initiate the connection from BT headset side button (ON/OFF button); then it goes on asking for the Password (0000) after which it stalls at Establishing Connection.

    What is the meaning of this? Is it my Treo 650 or something else?

    I also tried some Motorola BT headset but was never successful pairing it up with my Treo650 other then being able to input the password and stalling again at Establishing Connection.

    What is going on here?

  2. #2  
    Sounds like an issue with the phone. I know there is an issue with the HBH-300 and pairing problems. But with the 600 there shouldn't be any. Most Treo sites talk about the fact that the 300 is Treo compatible.

    I would take the phone back (send it back) and ask for a new one!!!


Posting Permissions