Results 1 to 4 of 4
  1.    #1  
    I let my 600 go dead a few weekends ago. I noticed it was off while driving so I tried to plug it in to my IGO adapter. It didn't come on. So, when I arrived where I was going I hooked up the cradle and it appeared to start charging. It never went above 60% and the charging indicator was alternating between green and red. I tried a soft, hard & battery reset (in that order) and it still would not charge properly. So I bought a new battery and installed it. The indicator still alternates between green and red while charging. The new battery appeared to charge to 100% after 48 hrs but depleted rapidly and will not charge to 100% even overnight.
    I do not have a warranty on the unit nor insurance.
    The only thing I have not tried is to let the new battery go back down to dead, might this work?
  2. #2  
    Bad charger, I suspect.

    I had a 3rd party charger for my Treo that started doing the red/green LED thing, and wouldn't charge properly. My OEM charger still worked fine, however. I got the vendor to replace the charger and the Treo worked fine on both chargers again.
    Bob Meyer
    I'm out of my mind. But feel free to leave a message.
  3.    #3  
    Unfortunately it does it with all 4 different chargers I have!
  4.    #4  
    OK, so i tried everything. So I took it to the Verizon store and talked to the service tech. He couldn't do anything but suggested I contact "Data services" ( I told him it was an e-bay item) and he said to try anyway. I did, and they sent me a new one. I guess I did have the original warranty as it was less than 1 yr old.
    New unit is fine so far.

Posting Permissions