Results 1 to 9 of 9
  1.    #1  
    I seem to have a major problem here...

    I've got a 650 Cingular version and the touchscreen doesn't work. I mean that if you try to "tap" nothing happens. I've tried soft reset. I've tried hard reset. Still no "tap."

    Also, for instance, if you are on main screen and hit the drop down menu button, the arrow navigator will not let you go to the right.

    While looking at applications, you can scroll to the right, however.

    I'm running missing sync, versamail, butler, treoguard and salexo's texas hold em.

    Other than that, plain vanilla.

    Cingular was overnighting me a replacement but they managed to screw that up so I've got another day or two to mess around with this one. Any suggestions?
  2. #2  
    Not that I think it will help much, but you could try removing the battery for a few minutes in effect doing a hardware reset. Also, if you have a screen protector, remove that. And check for any debris caught between the plasic frame and the screen surface.


    SprintPCS 650 since Nov 2004
  3. #3  
    screen protectors are a;ways the cause....
  4.    #4  
    Ah, there was that...I had a screen protector on there but took it off and have tried to clean as best I could for the last three days. Still no luck...

    I guess I'll try battery option...
  5. #5  
    Did the problem start before or after removing the protector ?


    SprintPCS 650 since Nov 2004
  6.    #6  
    Before the protector was taken off....
  7. #7  
    Time for a replacement.
  8. #8  
    My phone did something similar... The touch screen wouldn't work, and the down button seemed to be stuck, but actually wasn't (whenever I opened an app, or menu it would scroll down automatically)

    I hit the reset button about 3 times in a row and pulled the battery out for a few minutes... I put the battery back in let phone sit for about 20 minutes, and everything was back to normal. Haven't had a problem since.
  9. #9  
    Speak of the devil. I actually had this problem today when I was adjusting the screen protector so that it was more flush against the phone in the corners. After somewhat 'massaging'/twisting the treo it started working again. It had been working fine with this same screen protector for the past 60 days without incident.

Posting Permissions