Results 1 to 6 of 6
  1.    #1  
    My Treo 600 is not recognizing the sd card. Everything was fine for months but now it does not even know the card is inserted. I checked the card on my pc with a card reader and everything was fine. I transfered all the files to a USB jump memory stick. I tried to format the card in the treo and I got an error message "this card can not be formatted" I was able to format it with the card reader on my pc with no problem. Then I re-tried to format it in the treo and got the same message. I did a hard reset and now the treo does not even recognize that a card is inserted. I don't think anything is wrong with the sd card, could the sd slot in the treo have crapped out?
  2. #2  
    Do you have access to another card to determine whether the SD slot is bad?
    iPhone 4S
    Former Treo & Storm Owner
    Cigar Lover
  3. #3  
    Hmmm... Odd. No tone or anything when you insert the card? How are you formatting it on the Treo, cardinfo? Does cardinfo say "No Card Inserted" when you start it with the card in? If so, there is likely a problem w/the slot, if not, then the card isn't getting mounted correctly. In that case you can probably check it out using PalmInternals to see if the CRDI event is getting passed from the OS (card insertion) and the event that indicated that the card is mounted (which I forget just now). If the card insertion is detected, try reformatting the card on the PC as a FAT32 File System, then see if it mounts correctly in the palm.
  4.    #4  
    Robbalazs; No tone or anything when I insert the card. It use to beep but not anymore. I tried to format the card in card info and I got a message "This card can not be formatted" (It gives the same message if no card is inserted) Card info DOES NOT say "No Card Inserted" at any time. With or without the card in. I get Card: Unknown Type: Secure Digital Card Size: None The drop down menu does not even list a card option and my card info does not show up on my 2day application. I am not sure what you mean about "Palm Internals" could you explain more. Thanks
  5. #5  
    Looks like you have a corrupted card. Did the card pop out when one of your applications was trying to write to it? Or did you try to format the card in your PC card reader? Some users have reported problems when the card was formatted outside of the Treo.

    Another issue is that the Treo card reader could be bad, do you have access to another card and try that?
  6. #6  
    No beepage on insert is prolly not a good sign... PalmInternals is an application that allows you to see all of the Palm OS internal alarms, which applications are registered for which events, etc. You can google it, or head over to the Download section on MyTreo.Net... Get the latest version (1.9.46). Start it, press the "Ntf Tst" button, enter "crdi" (sans quotes) on the line in the dialog. Then put the card in. If there is an alert snowflake from the attention manager, then the OS "saw" the card insertion and sent notification of it. This could still be a bad slot, or a corrupt card, or a card formatted so that the Treo can't deal w/it. If there is NO snowflake, the OS didn't even notice that a card was inserted, and I'd be thinking bad slot, or VERY bad card, but you say that the card works in the PC...

    Of course the easiest test is to try a different card, if that works, it's not the Treo...

Posting Permissions