Results 1 to 5 of 5
  1.    #1  
    A few weeks ago I ran into the problem where the Treo Calendar would not sync with the Outlook calendar (even though, contacts, tasks and notes syncs fine). So i've been using just the Treo Calendar to keep track of events.

    Well, the treo crashed today and lost all the settings and several databases. I backed up the treo from yesterdays backup from 'BackupMan' and everything was restored successfully, EXCEPT the Calendar events. I get can error saying "There was an error restoring "CalendarDB-PDat" to your handheld."

    I have tons of events on the calendar that i NEED to have.

    How can I go about restoring them?

  2. mg48's Avatar
    541 Posts
    Global Posts
    678 Global Posts
    Sorry you missed it, but there is an already discussed issue with backupman, which I use, and leaving the 650's radio (phone) on while doing your backup. I corrupts the calender file. You'll have to go back and sync what you do have in outlook and reconstruct the rest. There is no recovering the corupt file.

    From now on turn the radio off before backing up. I use treo helper to turn it off at night, do an automatic backup, and the Treo helper turns it back on.
    Mike G

    Touch (Sprint)
  3.    #3  
    Thanks for the info. I wonder if "BackupMan" is the culprit in the other issue where the syncing with outlook calendar stopped working. I deleted the Treo Calender DB and started entering the items again, and now it syncs with outlook again. I havn't backed up, and I'm glad you responded to this before i did, because I was planning to after finishing putting all my events!
  4. #4  
    To fix your synci'ng, try running dbscan from to repair the corrupt database that prevents sync'ing.
    Palm III > Palm IIIx > HS Visor > HS Prism > iPaq 3650> Jornada 560 > nothing > Treo 650
  5. #5  
    I've had this same problem with both BackupMan and BackupBuddyVFS. Turning off the phone seems to often, but not always correct the issue. However, I have found that in the case of other data files that have the same error when attempting to restore from backup, that copying the file to my desktop (usualy just by inserting the sdcard into a card reader) and then installing the "corrupt" file through the regular hotsync installation process.

    I haven't verified this with the CalendarDB-Pdat.pdb yet, but I suspect it will fix your problem. Unfortunately, you can't just copy a file out of the BackupMan backup. I've asked the folks at bitsnbolts if they have a tool for extracting the file, but am not really holding out hope. Good luck!

Posting Permissions