Results 1 to 3 of 3
  1.    #1  
    Hi! I've read through the posts and tried a soft, hard, and "mega" reset on my new Treo 650 but nothing has worked. I got the Treo on Thursday afternoon and set it up on Friday morning. I didn't install any additional software other than the "Missing Sync" software so I could use more of the functionality with my G5. Anyway, last night I went to show a buddy of mine the phone and it appeared to be off. When I tried to turn it on nothing would happen. I was a little freaked out but figured that it was something easy I was missing. This morning I've gone through all of the sites that I can find and I've tried all the resets but the phone still appears to be dead. The indicator light doesn't come in when the charger is plugged into it, I've tried the resets with and without power, left the battery out for 30 minutes, removed the CIM card (it is the 64K that ends in A). I have the CIM from my other cingular phone and that it isn't working in it either. I have two questions: First, is there something I am missing or haven't tried? Second, how do I ensure that I get a new one from Cingular ASAP? I don't want to even entertain a replacement unit unless it is brand new in the box like this one was just two days ago.

    Thank you for your time,

  2. #2  
    You need to call Cingular ASAP and try to get a replacement. You can try going to your nearest store and make a fuss about not being able to be without a phone, maybe they can help IF, and thats a big IF, they have any 650s in stock.
    Cingular Treo 650
    Click here to see what's loaded on my Treo 650
    Do you like my dog? Visit his website!!!
  3.    #3  
    Quick update on this; I replaced the Treo on Sunday morning at a Cingular store. The Treo was completely dead and they didn't give me a hard time about a replacement. So far so good.. but I haven't loaded or hot-sync'ed anything yet.

Posting Permissions