Results 1 to 7 of 7
  1.    #1  
    Has anyone else noticed many of the Reset issues seem to point the the Preferences application (or DB?) Currently, when I tap the "Preferences" menu option in RealPlayer the unit resets every time. After the reset, if I enter "#*377" then "Dial" on the keypad after RealPlayer resets, I can see the error message "Preferences.c, Line:264,PrefDBOpen Error" as being the reason for the reset. I've seen this EXACT same error message from one other person on this board, though reporting a totally different issue. I also called palmOne, they had no solution at all to offer.

    Can anyone else confirm the same error on their device to help gauge how common this problem is? I thought my issue was related to a Bluetooth Hotsync that had corrupted a file, now I'm not so sure.

    My theory is that there is a corrupted record in the Preferences DB and the Preferences application itself is not cleanly handling the error. Or, it may be a bug in the Preferences application. I'm not sure which... I haven't run across any utilities that can scan the Preferences DB and remove any corrupt records, this may be a useful utility to develop until palmOne fixes the Preferences app. to be a bit more robust in it's error handling (hmmm...).
    Palm and PocketPC Development with CASL (make your own Treo apps, easily)
    CASL is here
    LibertyControl is here
    or visit WAGWARE Systems, Inc. here
  2. Devost's Avatar
    2 Posts
    Global Posts
    6 Global Posts
    This was enough of a problem for me to finally register here.

    I get this exact error when trying to send a picture via email.

    Can't get it fixed for the life of me, but all was working fine until today.

    Welcome any ideas....

  3. #3  
    I've encountered this problem today myself.. I was running BackupBuddyVFS and the Saved Preferences database wouldn't copy. I try to copy it from ZLauncher's file manager, and it tells me the database is corrupted.

    Anyone else know how to fix this? So far it *seems* to be working normally?
  4. #4  
    Does this bug have anything to do with a particularly nasty type of reset (after updating to ROM 1.08) that deletes your Saved Prefs?
  5. #5  
    Quote Originally Posted by acousticbiker
    Does this bug have anything to do with a particularly nasty type of reset (after updating to ROM 1.08) that deletes your Saved Prefs?
    It could be that rather than not getting saved to ram at all (Saved Prefs.pdb disapearing) that it's getting saved halfway?

    My solution yesterday was to look for my latest Saved Prefs.pdb on my sync computer and copy that to my SD card, then using ZLauncher copy that to the Palm, which worked fine and fixed the corrupt DB problem.

    I didn't compare exhaustively, but looking in Filez I didn't see much difference in the two files, there wasn't anything immediately obvious to me anyway. Both files were around 266k on the palm, etc.
  6. #6  
    i had the same crash problem when accessing the preference of realplayer. I was suspecting that removing of PocketTune caused the problem - because I changed the default player to PocketTune in the preference of realpalyer, then I deleted PocketTune, since then, system crashes.

    I performed a hard reset, then reinstalled (not restore) all apps except PocketTune to fix the problem.
  7. hlevin's Avatar
    38 Posts
    Global Posts
    58 Global Posts
    I've never seen that particular error, but there's definitely something wrong with the Preferences app. I use VersaMail as my default mail app instead of Xpressmail, so I've changed the e-mail button to access VersaMail. That is, until the next reset, when all of the preferences return to their defaults. I posted this on the P1 forums and (not surprisingly) received no answers back from P1.

Posting Permissions