Results 1 to 4 of 4
  1.    #1  
    Have only had my GSM 650 for a few days and just tried to use the wireless headset for the first time this morning. Headset works fine, but most of the time, when I unplug it, the phone doesn't go back to working as a normal phone. It seems to still think the headset is plugged in, so the internal mic doesn't work. Anyone else have this problem? Any suggestions?
  2. #2  
    I am not having that particular problem. But I do find it annoying that the eye piece does not ring when the phone rings. It can be hard to hear it in a noisy environment.
  3. #3  
    The problem here is that the internal switch in the mic socket (this flips sound from the front speaker to the headset) is sticking. This is probably just new component stiffness or pocket lint. Try blowing any junk out of the socket and then push the headset plug in and out vigorously a few times. I have often found this loosens a reluctant switch spring and you have no further trouble.

    If it fails, then send it back and get a replacement.
  4.    #4  
    Mwomwom, I think you were right. Jamming the plug in and out a few times, though lewd, seemed to have worked just fine. Hadn't noticed until it was back to normal that my Treo had stopped producing all of its normal little clicks and other UI sounds. With the switch set back, I get normal audio output.

    Thanks for the suggestion. Hopefully the switch will become a little better-behaved as it grows older.

Posting Permissions