Results 1 to 7 of 7
  1. hrlaser's Avatar
    440 Posts
    Global Posts
    442 Global Posts
    Hi.. I'm trying to get the Bluetooth keyboard known as the Freedom Input Keyboard (sold at to work on two different Treo 650s and failing miserably..

    They provide a PalmOS V5.x driver which works brilliantly on my Tapwave Zodiac 2. I can turn on the keyboard, turn on the Zodiac, launch their driver, turn on Bluetooth, it'll discover the keyboard, blammo, I'm typing into the Zodiac 2.

    On two different Treo 650s, one SprintPCS, the other ATT/Cingular, I get erratic behavior using exactly the same driver, and the Freedom Input says the keyboard is compatible and has been tested with the Treo 650 and is even featured on their front page..

    I installed their same driver, same one that's on the Zodiac 2, onto one of the phones, went through the same process as I did with the Zodiac 2.. turn on the keyboard, turn on the phone's Bluetooth, run their driver interface, it discovers the keyboard, I tell it to activate the keyboard, it beeps and works and I can type into te Treo 650 with it.. turn off the keyboard, turn off Bluetooth, turn them back on again, it doesn't work. Same thing on the other Treo 650. Exact same routine. It works ONCE after it's installed, and then doesn't work again.. it gives me an error message to "Check the power on my keyboard and try again" once it stops connecting..

    Meanwhile, back on the Zodiac 2, I can turn each device on and off, and it merrily connects to the Zodiac 2 every time, using exactly the same driver..

    Do any of you have the Freedom Input folding Bluetooth keyboard and are you successfully using it with a Treo 650??..

    If so, I need someone to give me a step by step of all the settings you are using in the keyboard's driver, and in the Treo 650's Bluetooth setup screen, and it's pulldown menus so I can see if I can duplicate your success..


  2. #2  
    Any luck getting this to work? If so, what did you do? I can get it to pair but it does not work.
  3. hrlaser's Avatar
    440 Posts
    Global Posts
    442 Global Posts
    Quote Originally Posted by wingetj
    Any luck getting this to work? If so, what did you do? I can get it to pair but it does not work.
    When the Treo 650 tried to pair with the keyboard, did its Bluetooth find it at all when they were both turned on??.. Did the keyboard's light blink in the proper sequence per the little instruction sheet that came with it??.. Did the Treo 650 ask you to enter a passkey and did you enter "0000" (four zeros)??..

    Well what I've done so far is to send my Treo 650's Blazer browser to where the Freedom Input people have uploaded a new driver for the keyboard in the form of a .prc file you can directly download with the Treo 650's browser and auto-install. It is a newer version and revision than the one that I originally had installed, so I downloaded it and installed it, but to be honest, {{blush}}.. I haven't had the chance to see if it solves the pairing problem yet.. the original driver DID work, but every time I turned the keyboard off and the phone's Bluetooth off, then went to turn them back on again, it wouldn't pair.. I'd have to delete bluetoothprefs to get it to work again.. but it DID work as long as I didn't turn them off..

    While I was reviewing the keyboard for the magazine, I reported this to the Freedom Input guys, and this may have resulted in this new driver being available, so I would say go to with your Treo 650's Blazer browser then download and install the newer driver.. then maybe you can come back and tell ME if it works correctly.. I've just had too much other stuff to deal with, like cranking out reviews for the magazine, to **** around with this new driver since I installed it.. but I do have high-level contacts at Freedom Input who I can talk to if it still doesn't work right..

    Like I said, the original driver DID work just fine, as long as I didn't turn the keyboard off and the phone's Bluetooth off.. this new driver was allegedly supposed to fix that problem..

    Do NOT send email to harv at treocentral dot com - it will never reach me.. forwarding from that address to my real address was hijacked in early 2008, and I can't fix it.. send me a private message instead or email me directly at my RR address..
  4. #4  
    I also have the Freedom keyboard. However, the driver does not seem to have changed at all. It is still version 1.50, which it has been for over a month. I have been able to get it to pair successfully. My big complaint is that it does not support 5-way navigation, despite what the manual says about using the alt-green key.
  5. #5  
    bump, im having same problem.. nothings working so far, anyone get this to work right?
  6. #6  
    And I really wanted to get this keyboard; after all I've read, I didnt expect that it would have a problem with the 650.
    ~ ScandaLous ~
  7. #7  
    it is the treo's bluetooth quality. it sucks. until they release a firmware update, we are all sol. I heard Sprint will release one soon...

Posting Permissions