Results 1 to 2 of 2
  1.    #1  
    After many hours of frustration dealing with openobex to send files to my Treo 650 from Linux I finally decided to look for something else. Doing a search in available packages on my Mandrake Linux box I found the gnome bluetooth subsystem. I don't use gnome, but it works all the same. I installed this and found a nice little app called gnome-obex-send. I tried it out and to my surprise it worked perfectly. It gives you a list of devices you can send to as well as lets you scan for more. I then discovered that there is a command line option to specifiy the address directly to the device so you can skip clicking on it. The only thing I didn't like was the big chunk of data it outputs. So I wrote a tiny bash script to silence that. I am now left with the simple command:
    > btsend file.prc
    A box pops up, shows the transfer status, then my treo beeps and it asks what I want to do with it. Quite simple, quite effective. To do this all you need is the gnome bluetooth subsystem (regardless of which desktop env you use) and the bash script I wrote. Here are some links:

    Gnome BT Subsystem
    My bash script

    If you have a recent version of Mandrake you can just use the software installer and it should be listed. I hope this helps.
  2. #2  
    I had a much easier time setting up Bluetooth using SUSE 9.2 and KBluetoothD. I routinely install programs with the OBEX Push Client. You might want to check into KBluetoothD. I have not fully attempted any sync functions.
    I still have problems with Bluetooth and WinXP. Getting the DLInk BT-120 PC adapter working took forever, and it still doesn't work right. With Linux, the adapter was automatically recognized and I was up and running in a few minutes.

Posting Permissions