thanks for your repy, just to clarify wht I am trying to do is play .mov or quictime files on the SX66 which plays WMP or I hear betaplayer to. ( at least I am trying)

Here is what I did:

2) Quicktime Pro can export to AVI
3) Pick up a USB SD card reader and an SD card - the size of the SD card will be determined by the size of the videos you intend to play on the device - you can get a card reader for about $30. You can get a 256MB SD card for $50 or less, a 1GB card for about $100 if you look around. You can pick up both at CompUSA, BestBuy, Fry's, etc.
4) Use QTPro to export the '.mov' file to AVI, drag and drop onto your SD volume, place SD card into SX-66, load WMP, tap playlist, you should see the converted file, tap it and it should play

Thats what I thougt and I tried exactly that


I can see the files with file explorer but I cant
get them to do anything on the SD card.

Also: separate issue but
ok. no luck with reciving email (can send) or using wifi but here is what I have done so far with the
video trying to get quicktime or .mov files to play on SX66:

got qt pro>imported .mov file to FCP >exported as .avi

downloaded beta player.arms.cabs.unstable
cause Iheard it might play .mov files

put beta player
.mov file
.avi file ALL on 1 gig
sd card on usb card reader

transfered card to SX66
cant see any files but the mem is less

cany find on wmp playlist
but when i do a search for files bigger than 64kb
there they are!

6) also can now see them all in file explorer under
storage card!

Where I am at:


when i try to open or play these files get this error message:

" there is no applicatrion associated, run application first then open this file from within the application"

but when I try that it doesnt work. I have also tried opening the app from WMP playlist (doesn't show up)

Any suggestions as to next step would really be welcome . we are so close!

I put the stuff under a file called avi and movies, I also downloaded beta player
directly to the sd card from the internet..both ways give me the same error
i can see the programs and files, but i cant open any of them yet..