My Treo has worked fine...but this weekend in California it was almost useless. Half the time, when I tried to call, it showed 2-3 bars but after dialing it would request my phone unlock code. I'd enter it but it sometimes was slow to take my keystrokes and then I had to start the call all over. At other times I'd be in a call and it would suddenly drop the call and ask for the unlock code. I thought it might be related to poor reception but it seemed to happen even when I had 4 bars. Then I thought it might be California, but now it's beginning to do the same thing back home in Illinois.

I saw an old thread here about problems with 600s when their batteries don't hold the charge (altho mine seems fine for a day or even two) they begin to suddenly reset or do network searches. Maybe that's what's happening since a network search would drop the current connection and require that I reenter the code when it found the network. I'll going to try to elminate the unlock code and see what happens.

Has anyone else had this problem?