Results 1 to 12 of 12
  1.    #1  
    Hi all,

    Cruised the search but didn't find quite this situation, was hoping someone else has seen it and can relate.

    I have a Treo 650 using ZLauncher for most of my non-essential apps (moved to the memory card), while the main memory is mostly taken up with GoodLink, SplashID and SplashShopper. I don't think GoodLink *can* be moved to the card and remain functional, and the Splash items I want in memory so they will sync with the desktop.

    So that leaves me with about 5 megs of free memory (as reported by ZLauncher info). Which should be fine, right?

    Well.. If I use my Treo 650 for about half a day (primarily in GoodLink), after a while I can no longer launch other apps, either from ZLauncher or from the Palm app launcher. Any time I try, I get various error messages telling me I'm out of memory. Blazer comes up with a dialogue entitled "Download Error", and the text reads:

    "There is not enough memory available on your device. You can free up memory by deleting files or moving them to an expansion card."

    Trying to launch apps from ZLauncher gives me:

    "Database: Out of memory. Delete old data or unneeded applications (Dm 0201)"

    But I have 5 megs free!

    The only way out of this is a soft-reset, which lets me launch apps again.

    Any thoughts? Is this just another manifestation of the Treo being short on memory? It is a pain in the **** to have to keep soft-resetting my Treo when it decides it's out of memory. I can't even see any indication that it's getting close, because the only meter I can check shows me I have 5 megs free.



  2. jimmyz's Avatar
    38 Posts
    Global Posts
    85 Global Posts
    I've started having exactly the same problems!!! Its really a pain when trying to surf the web using Blazer
  3.    #3  
    Yeah.. it happens a lot and it's really annoying.

    I suspect what the error messages are really talking about is the 10 megs of space that is reserved for running applications. This is discussed in the article on Palm's web site that details exactly how the NVRAM file system works:

    Palm KnowledgeBase Article


    "NVFS on a Treo 650 operates in a similar fashion to a PC's hard disk storage. In addition to the non-volatile memory, the Treo 650 includes 10MB of true RAM. Applications are copied from the Treo 650's non-volatile memory to the RAM in order to be run."

    So what I suspect the messages mean is that there is no more space in RAM, versus storage. However, there is no way (it would seem) to see how much RAM is actually available, and what is taking up the space. Perhaps some sort of utility could be written to do this, but I don't know if there's an API call to discover this information.

    I suspect I'm seeing it more because GoodLink takes up a good portion of that 10meg RAM space, leaving not much left for anything else.

    I did make the situation a little better by *removing* ZLauncher. Turns out that takes up a good chunk of RAM as well, and it also never seems to exit. That, plus GoodLink, made my Treo 650 pretty well useless.

    I still get that error, but it only happens after a longer period of time and only after I've launched many apps.

    One thing to note: Bejeweled 2 will *not* run on my Treo no matter what. I haven't tried it without GoodLink installed, but it's possible that it's just too big for the 10 meg RAM space. (Has anyone else gotten it to run?)

    Two things would be great:

    - An indicator for the size of RAM available, as well as a list of applications running and occupying that space (possibly with an option to terminate an app).

    - A way to increase the size of RAM, taken out of storage space. I'd happily trade a few more megs of storage for larger RAM.

    Anyone else have any thoughts on it?


  4. #4  
    Yeah, I get this error many times too and it really annoying. I'm pretty sure it's due to palmone's "brilliant" use of the new memory.

    I had the error yesterday when launching Quicksheet from the card. One of the files moved with it was an 88K spreadsheet file. By the time it got into the Treo's main memory that same file exploded to over 1400K - not 140, but 1400 - as in over 1 MB!!! (file sizes according to Resco Explorer)

    How can palmone think that's acceptable? Multiply that times many apps and databases and you can easily see there's a serious problem. I have to sacrifice some of my apps with desktop sync capability because there's just no room for them in main memory - and or course they won't sync from the card.

    More and more frustrated every day....
  5. #5  
    Quote Originally Posted by mnc042
    I did make the situation a little better by *removing* ZLauncher.
    As much as I love ZLauncher, I've considered doing that too, solely to free up some memory. The problem is that I'd have to use PowerRun or some other program to launch the apps stored on the card. I've found that ZL does that better than PowerRun (if the Treo resets during use of one of the stored apps, ZL "remembers" and will move the app back after the reset; PowerRun will not from what I remember).
  6. #6  
    I have 7.5 Meg free and still get the "out of memory" error quite a bit...a soft-reset corrects this...but this is a huge problem for Palm if they don't correct this memory issue soon. The members of this forum can solve just about anything...but for the 99% of Treo users who are not technically attuned, and don't even know this forum exists, I suspect they will just get frustrated and return the phone. It does seem like we are the Beta Testers for the 650...wish we would have gotten a final release :-(

  7. #7  
    Bejeweled 2 has worked for me from day 1. I have 8.5 megs free and am using ZLauncher. If you can get into B2, try going into Options and turning off some of the graphics or the 'shimmer' effect. I read somewhere that the effects take up a lot of memory.

    Also, I have Blazer set to clear the Cache on exit and am using SnapperMail instead of Versamail. Yeah, Blazer exits slowly sometimes, but I hardly ever experience the 'Out of Memory' error anymore.
  8. #8  
    i use powerrun and have 18.8mb AVAILABLE, i moved almost everything to the card except LEDoff, KBlightsoff and keycaps600. I have over 1000 contacts and a calander that goes back to year 2000. Powerrun takes about 100kb and is very powerfull, i like not having to deal with zlauncher's UI.
    Treoing & Loving it
  9. #9  
    I do not understand what the big rush was to released a flawed product.
  10.    #10  
    I think part of the confusion when we talk about "memory issues" is that there are really two different memory changes on the Treo 650.

    First, the NVRAM issue that affects the amount of *storage* space. This has been reduced due to the bookkeeping overhead, true, and that's what a lot of people notice immediately -- they can store fewer apps in the device. This is where ZLauncher and similar utilities can help, by managing the offloading of storage onto the SD card.

    But I'm seeing another, more troublesome problem with the whole way the memory was redesigned to *run* applications.

    Now that the Palm has the notion of separate storage space and RAM for execution, it seems to me that they didn't leave enough room to really run applications the way we're all used to doing it. Now that apps have to be copied from storage to RAM, and then executed, this new area is filling up.

    Some people won't see this, as they tend not to run apps that take a ton of runnable space, mostly storage space. But I'll wager anyone running GoodLink (which takes up, I'm guessing, a lot of the RAM) will see this almost immediately, as I did.

    Again, it's not a lack of *storage* space -- I've managed it so I have about 6 megs free of storage. It's lack of RAM space for the apps I want to run.

    Worse yet, there's no way to monitor how much of this space is available, nor any way to really manage the memory.

    Finally, I personally believe there is a memory leak in there somewhere. It feels to me like apps are running and then failing to release memory they've allocated. This could be what Palm means when they say that some apps won't "like" the new NVRAM file system... or it could be a problem somewhere in the new scheme on the device.

    Bottom line, I really, really hope PalmOne addresses BOTH issues when they issue the memory patch. They need to reduce the overhead that is incurred when storing files internally, which will help. But the killer fix will be increasing the amount of RAM available to running apps, or at least implementing a system that allows you to page in storage from other sources (like the SD card) and make it appear as RAM.

    At the very least, a way to monitor and control the amount of RAM in use would be good... but I fear the device will not be truly useful if they can't up the RAM allocation. (Does anyone know if the 10 megs is a soft limit or a hard limit? i.e., did they stick in 10 megs of old-style RAM in there in addition to the NVRAM, or is it a virtual RAM space implemented in software?)

    The device is such a good one... but this really hobbles its usefulness..

  11. #11  
    In dealing with the battery drain issue, I discovered that, for me, PTunes was not really shutting off after I had been playing some streaming audio. It was just "paused" no matter what I did but was still, apparantly, actively running. Something like that HAS to be taking up some RAM even if not much. I also suspect my alarm apps and others are taking up the "operating RAM" as well.

    Definitly need a resource manager to see what apps are active and using memory
  12. #12  
    I have GoodLink, SplashPhoto 4.32, SnapperMail, pTunes 3.0.8... and I also get the same error when trying to open Blazer.

    Does everyone in this thread who reported the error run GoodLink and/or some of these apps?

    BTW - I have 7.1MB free

Posting Permissions