Results 1 to 10 of 10
  1.    #1  
    My headset is fully charged and paired (already talked extensively on it). Now when it is switched on & I tap on button, it starts flashing blue rapidly beeping in my ear. This will not stop when I make or receive call. Only way to stop it is truning it off. When I turn it on again & tap on button, it starts again. What is going on? Everything seems fime until I tap the button at any time... Help!
  2.    #2  
  3. #3  
    By an chance did you RTFM? Sounds like your BT G2 may be defective. I would try another one and see if I get the same results.
    ~ ScandaLous ~
  4.    #4  
    yes i read it!! but i have no eyes... :-/. I tried everything! Do you have the g2? yours never did this? i even tried a "force headset only" pairing from website troubleshooting
  5. #5  
    I'm only a day into using G2 w/ 650- but haven't experienced anything like that. I do know if the wi-fi in my laptop is enabled it doesn't work for @$#%
  6.    #6  
    these slowpokes at bluetrek won't email a response to my problem...
  7. #7  
    Mine beeps when I turn it on and I hate it. I think its searching for a signal from the phone. Make sure you phone is on (the display is on), so the Bluetooth can communicate. My beeping goes away when my display is on. If it isn't on, it will beep for a very long time. After it has found the signal, it will stop beeping until you shut off, and then re-power the G2.
  8. #8  
    "I have the same problem even though I repaired a couple times. I can only answer call on Treo."
    Beeping seem to disappear if I turn on the Autoanswer in Treo Hadnsfree Preferences
  9. #9  
    Any of you having loud static problems?
    [ T650 | SPCS | DC ] FREE - Palm | Computer | PVP | iPod | PreModed XBOX | GEAR
  10.    #10  
    yes i get sporatic static! but sometimes i walk into the kitchen with the phone still in my bedroom. i forget because there is barely any static! has anyone returned their headset for another one that functioned corrcetly. the support at at vluetrek is horrible. i sent two emails with NO response!! no wonder the headset is $28!!!

Posting Permissions