Results 1 to 3 of 3
  1.    #1  
    Wow ... this is bizarre. When I got in the car to drive home from work my Treo was fine with about 85% battery left. As I was half way home I picked it up to make a call and it was dead. I tried a pin reset but nothing, no life in it at all. When I got home I plugged it into the charger cable and it blinked and came to life at the calibration screen - - it hard reset itself. The battery showed about 84% at that point.

    Bizarre. I have NO idea what caused this to happen. I have not had any problems that I am aware of. I do have a number of utilities running such as TreoButler, CallShield and TreoGuard. Thank goodness for BackupMan!

    Has this happened to anyone else?
  2. #2  
    Mine did the same at about the same level of charge when it was seven days old in July. It has worked fine ever since without problem. I had made one call. I have no idea what happened. My guess would be a battery issue of some type.
  3. #3  
    Mine does this too..Goes from 100% to talking to someone to dying in mid of a 2 minute conversation. Goes to 40%. I plug it in and it goes back to 100% if it is not locked up.

Posting Permissions