Results 1 to 8 of 8
  1.    #1  
    My treo wont charge whether it's pluged into the wall or through my laptop, it beeps, icon on, icon off repeatedly. tried hard reset already. any suggestions?
  2. #2  
    What are you using to charge it? The standard charger? Anything else would be suspect in my book.

    If you are using the standard charger or a Handspring car or USB cable charger then I would go to the Battery reset to try to get it working again. Hold down K and backspace keys while performing a soft reset.

    The other possibility you should consider is that your battery is worn out - Treo is getting to the year+ mark now on the market. If you abused your battery thru overheating or thru constantly discharging to extreme low battery rather than top-up charging. Still - this scenario is unlikely because the fallof in capacity is usually gradual rather than abrupt.
  3. #3  
    Maybe a "Battery Disconnect" would solve it?

    Battery Disconnect Reset

    A battery disconnect reset is a last resort step you can take to cut battery power, wipe all data, and regress a Treo 600 to its factory-fresh state. It only works on a Treo 600 smartphone.

    Warning: A battery disconnect reset will erase everything on your device, and also reset the wireless radio and disconnect the internal battery. All your data will be removed, and your formats, preferences and other settings are restored to their factory default settings. Don't perform a battery disconnect reset unless you've backed up your data, or you're willing to lose everything.

    Additionally, you won't be able to turn your Treo 600 back on until you connect it to a power adapter, so do not perform this type of reset if you're not near a power source and your Treo 600 charger.

    HotSync note: Some third-party applications change the way your handheld backs up data. Other third-party applications do not back up data. If you have third-party software on your device, please contact the developer to learn what components are backed up during a HotSync operation, and if HotSync conduits are altered. Any data not backed up will be lost.

    1. Disconnect your Treo 600 from the AC charger.

    2. Hold down the K and Backspace keys simultaneously. (Note: for French AZERTY keyboard, press K and M; for other language overlays, please refer to the customer support for your region)

    3. While continuing to hold down the K and Backspace keys, press the RESET button inside the hole on the back panel of your device (where's the reset hole?).

    4. Finding it hard to do? Good. We made this type of reset very awkward to perform, so that it would not happen by accident when your Treo 600 is jostling around in a pocket or bag. Sorry for the inconvenience. You might want to enlist the help of a dextrous friend if you find it too difficult.

    5. Continue holding down K and Backspace. The screen will flash white briefly, and then go black. Release K and Backspace after this happens.

    6. To revive your Treo 600, connect it to the AC charger and plug the charger into a socket. The screen will stay blank for several seconds (as long as half a minute), then it will turn on. The LED will glow solid red, indicating charging.

    7. Finally, follow the steps for recovering after a hard reset (a battery disconnect reset is a type of hard reset).
  4.    #4  
    thanks, yes, i'm using the standard charger either directly into the socket or connected with the hotsync.... and the car charger, it is doing the same with all. i will try the battery disconnect reset. it is a new, replacement phone, so the batterery shouldn't be worn out yet. i've had it for one month.
  5.    #5  
    hi there, well i did the battery reset and it's still doing the same thing and not charging. unfortunately i'm working in europe and i can't easily replace it. any other suggestions???? thanks so much. -i love my treo but i'm very frustrated....
  6. #6  
    It sounds like you have a problem unit. I cannot think of anything but dirt clogging the USB port on the Treo (check for debris) which is preventing the pins from connecting. This is always worth checking.

    You can get warranty service in Europe from palmOne for Treos. Check out the links at for the local sites.
  7. #7  
    I too have this charging problem suddenly, as I described here:
    I am now working it as a charging problem, and no longer as a hard reset problem.

    I tried the batt reset, and there is no change in behavior when I charge, which is that after a few minutes the LED is solid green, but will occasionally flash red, and the batt icon is a solid half-full batt with a green lighting bold over it, which simultaniously becomes a red lighting bolt with the occasional red flash of the LED.
    When I unplug the OEM charger from the wall, the batt icon shows less than half, and tapping the icon says it is 36%. I assume that is accurate.

    The only hope I have is that the hard reset wiped out the firmware update, and the firmware update had resolved any charging issues. I will check it out.
    Any ideas about it?
  8. #8  
    Just an update, you may find this interesting...

    Assuring that I had the exact charger which came with the Treo 600, as opposed to the old Treo 180 made no difference at all. Same problem.
    I did several batt resets; same problem.
    The latest firmware was still loaded (guess that's why it's called "firmware"), so that was no problemo.
    It couldn't be the connectors: the Treo does indeed go into charge mode at first.
    After reading many threads I started playing with the radio status.

    What I have now is that only if the radio is on and the network is acquired (I have a GSM model, from Orange in Switzerland) will the charging advance. The charging has now gone from 40% to 64% in the 38 minutes since the last reset.
    Since doing a HotSync to restore data, now I can charge with the radio off.
    Last edited by Rob010101; 09/10/2004 at 08:28 AM.

Posting Permissions