Results 1 to 6 of 6
  1.    #1  

    I was on a business trip and on the flight I had to shut off my Treo 180. Upon landing I tried to turn it back on and it would not turn on. I then tried 2 charge it but it would not accept the charge or turn on or do anything. I tried to re-set it but nothing worked.

    Any thoughts or insights into possible reasons for this as well as any fix would be greatly appreciated. Thanks and regards.

  2. #2  
    Could be loose internal connection as some had reported that problem. Hope you can still get it replaced.

    Did you try leaving it the whole day on the charger? I had this problem but then it turned out to be hardware issue on the 180. Charging circuit failure.
  3.    #3  
    Thanks for the insight. Will try charging all day and will also try and call Palm 1 about this. Much apppreciated.
  4. #4  
    I can help u to sovle this problem
    but U seems too far away from me
    I m Mr.Right
    treolover: treo 180 - >treo 270 ->treo 600
  5. #5  
    Quote Originally Posted by laic123
    I can help u to sovle this problem
    but U seems too far away from me
    Can you just give mnalla the step by step process?
  6. #6  
    Best call Treo service or your service provider. Mine has crapped out twice. The first time, T-Mobile replaced it saying they were going to charge me $70. They replaced but forgot to charge me. I am expecting another one this week and hope for the same administrative treatment.

    Jeff in NYC

Posting Permissions