Results 1 to 7 of 7
  1.    #1  
    I have used 4 different SD cards now (all SanDisk 512MB).

    I have formatted the cards with the the Treo and have them about 70% full (mostly with games, pictures, MP3s, etc.).

    The only thing that consistently writes to the card daily is backupman (once a night).

    After some period of time (usually weeks), the card becomes unreadable. I have used programs to test the integrity and have always been able to format the card, copy all the data back and use again for several more weeks.

    I would have suspected the cards, but as I mention I have used several cards over a period of months with the same behavior.

    Anyone else ever notice anything like this? I can't seem to pinpoint the problem and it certainally isn't very consistent whatever it is.

  2. #2  
    Are you using a card reader on a PC with the SD cards ?
  3. #3  
    I've had scrabling issues too. Though my problems have been relegated, exclusively to the DCIM (pictures) directory. I've tried formatting the cards, checking them in a card reader, etc. They all appear to work fine on the PC, but they all eventually get scrambled with my (Sprint) 600. I feel that it's definetely a phone issue.

  4. #4  
    I had this problem too with a 1GB card. After much frustration, I replaced the USB 1.1 SD reader on my PC with an updated USB 2.0 one. Magically, all problems went away. It appears that when I plugged the SD card into the old reader, it created small data errors in the directory of the card, and these mounted over time to failure. Since I have replaced the PC reader, I have had no problems with card corruption at all in 5 months.
  5. #5  
    I've been using the same card as you driddle (Sandisk 512 & 256) with my Treo and digital camera with no problems. Also, I've been reading the cards with a just a plain old USB 1.1 reader.

    Do you have another device that can use an SD card? I sounds like a phone or reader issue.
    Truth is good, knowledge is power and it's the second mouse who gets the cheese
  6. #6  
    Yup - let's not jump to any quick conclusions here about hardware problems

    What exact models of SD card are you using manufacturer, model number, capacity? There are lots of variants out there right now with different encryption hardware, access speed and other enhancements e.g. the new Ultra SD cards.

    For those that have seen corruption, how do you write files to the card? What other devices do you insert the SD cards into? I would also suspect the reoutine backups as potential causes.
  7.    #7  
    Thanks for the responses.

    After formatting the card on the Treo, I use a card reader just one time (it's a Dazzle 8-in-1 USB card reader)

    to preload my card with the pictures, MP3s, etc. After that, I put it back in the Treo and use it that way for weeks before I typically see a problem.

    If it was a card reader issue, the problem sure shows a long time after I use it.

    As I mentioned the only thing that writes to the card afterwards is backupman.

    I haven't tried disabling this and/or never using the Dazzle card reader yet (i.e. I could preload with CardExport or something).

Posting Permissions