Results 1 to 3 of 3
  1.    #1  
    yesterday my Treo 270 started acting funny, while i recharged it and saw that the battery was full, i discovered that the green light was not going stayed on..i wanted to use the phone but nothing happened everything was stucked.

    Than the screen went black and i couldn't switch it on again... i tried the soft reset method, no result, with the hard reset i manage to get a blue screen...but thats all, later i tried it again and the palm logo appeared...but no result, than did a hard reset again and i manage to get it showing the Yes/No option....i deleted all the old files and prgrs on it (i have a back-up) and wanted to start fresh...the Treo was working for a couple of minutes than it dropped dead again... and now the hard reset method doesn't do anything.....

    is it the battery ? can it be replaced ?
    i try to open up the Treo but didn't manage..

    anybody solutions or tips for me.....overhere where i live Handspring stop their services......and i bought the unit i hope it can be repaired.
  2. #2  
    Ibanez. I posted a solution earlier. Try the HARD RESET while you are plugged into the charger. Then leave it on the charger for at least 2 hours. Apparently this works for most cases. However, if it still hangs and refuses to charge then you have only one choice - send it to the manufacturers.
  3. #3  
    You might wanna try the In-cradle reset where you would plug the unit to the charger then do a soft reset. Or try to push down the power button a number of times. Goodluck!

Posting Permissions