Page 1 of 2 12 LastLast
Results 1 to 20 of 21
  1.    #1  
    Hello Everyone:

    I've encountered a very strange bug after I ran the latest update. I have an unbranded international gsm phone and the update went through fine.

    However, after the update I cannot seem to type any text using the native sms program. I receive messages fine but can't type anything in the body of the message. In fact, I cannot even use quicktext or paste anything there. Strangely enough, third party SMS programs like MaxTEXT work fine.

    I did a hard reset and then it works for a few minutes. Once I use gprs it stops functioning again. Just weird!!!

    Has anybody encountered a problem like this? Any help would be appreciated.

  2. #2  
    What network are you on? and country?
  3.    #3  
    I am in India using Airtel.
  4. #4  
    Does Airtel use GPRS for it's SMS transport? This could be the problem. Some countries are moving their SMS services to GPRS rather than the regular method. It may be worth asking them if they made changes.

    Otherwise, I can only think you have a weird bug introduced by the updater or perhaps a physical problem with the Treo causing this odd behavior.
  5.    #5  
    Thanks. I asked them and they said they continue to use the regular method. But its interesting you said that. I have a T-mobile card from the US and that works fine here (however the phone doesn't detect a gprs network when I use that). I am heading to the US in the next few days and it will be interesting to see if the problem recreates there when there is a GPRS network also.

    Also I tried hard reset > reinstall update > hard reset > restore backup and it still didn't fix it.

    Maybe they screwed up their sms program since I can't believe a third party software can work fine for a basic need such as SMS but Treo's native program doesn't.
  6. joele's Avatar
    313 Posts
    Global Posts
    320 Global Posts
    Quote Originally Posted by desitreo
    I can't believe a third party software can work fine for a basic need such as SMS but Treo's native program doesn't.
    This has been the case for a fair few of us since the first firmware, slightly different problem but still bugs in the SMS program, that PalmOne don't want to know about!
  7.    #7  
    Strangely enough it works perfectly fine now that i am in the US though. Maybe it has to do with some setting in the Indian network which causes a bug on the treo
  8. #8  
    Hi Desitreo,

    I have the same problem, and I use Orange network in Mumbai, India.
    If you find a fix do let me know.

  9. joele's Avatar
    313 Posts
    Global Posts
    320 Global Posts
    P.S. I am with Optus in Australia
  10.    #10  
    I talked to PalmOne support in the US. They have given me a reset code that resets all the circuits in the phone and drains the battery. Apparently this might help. I am thinking about Trying it when I get back to India. Otherwise, its back to MaxTEXT.
  11. #11  
    What are the reset codes and battery power down. By pressing K and Space Bar and the reset all togather did not power down the treo.
  12.    #12  
    I think it is K+backspace+reset. I really wouldn't try it without talking to someone at palmone first. Might as well fork over $20 to buy MaxTEXT or the equivalent SMS program.
  13. #13  
    The "reset" code is actually factory reset..and it does indeed work. Its the last ditch reset when everything else fails. As far as the SMS issue is concerned, it dosent help after the GPRS network is detected. The current solution that works for me for f/w 3.04 (patched-unlocked) is to disable the Treo from preloading the GPRS settings for Orange. Now mind you, the settings that are preloaded..arent the ones for T-Mobile, Cingular or AT&T which are locked..and hence cannot be changed..rather they are "semi-locked". Check to see if the same happens with Airtel too.
  14. #14  
    Good news guys, go to and request Mol for the Texter.prc file,
    install and carry out a soft reset and your SMS problems are over.
  15. #15  
    The file is available now from the Downloads/Treo Utilities section.
  16.    #16  
    Mol: I am unable to find the file texter.prc on Is that the name of the file? Thanks
  17. #17  
    Hi! I am also based in delhi and use the Treo 600 with GSM service through Airtel. Somewhere in this thread I found the solution....the file texter.prc is available for download at The file is located under the common name, "SMS No Limits" in Treo Utilities. IT WORKS!!
    Thanks Mol!!!:-)) I am a happy Treo user!
  18. #18  
    The url for downloading texter.prc is:
  19. #19  

    I was facing the same problem of not being able to type outgoing SMS. However, I am not a GPRS subscriber -- on a battery reset, it worked only as long as I didnt make an outgoing call.

    Now it works fine, except the known issue of Options->Preferences not working -- if anyone gets to know of a fix to that, pls let me know. Would really like to get to type names instead of numbers in the address field for SMS.

  20. #20  
    Here's the solution to this problem:

    Download the latest version of the carrier settings from palmOne using the Treo 600 desktop installer; remember where it says "do you want to download the latest setting from the Internet?". The SMS application reads the settings file to look for SMS settings by carrier (for example, a SIM from another carrier will behave differently if you happen to be roaming and using pay as you go). palmOne support has re-issued the carrier settings on their website. The new version should fix the issue for anyone who had the SMS text limit.
Page 1 of 2 12 LastLast

Posting Permissions