Results 1 to 14 of 14
  1.    #1  
    I just went to
    and they have now released the software upgrade for unbranded Treo's.
  2. #2  
    It says not for North America. Someone download and install it and tell me how it is.
  3. #3  
    If they released this one for GSM, it has to be only days before we get the Cingular, ATT and TMobile versions. I tried it on a Cingular T600 and the updater refused to install.
  4.    #4  
    I am doing the upgrade right now. I will let you know how it goes.
  5. doum's Avatar
    7 Posts
    I just did it for my Treo600 (Rogers). It rebooted constantly after the first Hotsync when trying to activate GSM. A long press on the GSM on/off button and 2-3 reboots later it was updating the firmware. I suspect this was caused by one forgotten application that activates GSM upon soft reset.

    Everything looks fine Can't wait to try the sound recording, this is the only thing that I miss from my T|T.
  6. #6  
    Australia - unbranded - GSM - Optus Network

    New firmware boots okay, but after hotsyncing to restore my data, I get an endless loop of soft resets. Same after restoring backed up files from SD card.

    I'm guessing it's a newly incompatible 3rd party app.

    EDIT: despite selectively restoring for 2 hours I can't work which app is causing the crash. Going to reinstall the 3.04 firmware.

    EDIT: 3.04 firmware now says "this update is not for this phone". So I guess I have to reinstall everything from scratch
    Last edited by Virt; 05/17/2004 at 09:27 PM.
  7.    #7  
    I am from Australia too.
    Unbranded - GSM & Optus.
    The restore hotsync froze on the mempad so I deleted it from the backup and all is good.

  8. #8  
    Worked fine for me after an initial problem. I posted about it here if you're interested.
  9. #9  
    Have a good read of the CDMA upgrade thread - there's lots of good ideas and caveats in there.

    I just ran the updater successfully on my GSM unit. I have a pay as you go SIM from Asia that I use when traveling. It took about 5 minutes to flash.

    Here is a small distillation of the problems seen by Sprint users - mostly looping resets after the install. It seems likely that the issues won't differ on GSM (I use both):

    - Launcher applications like Launcher X should ideally be deactivated before the update
    - Treo helper applications like Butler, TreoHelper, TreoTools should be off
    - Ringtone applications like LightWav should be deactivated
    - Skinner and other applications that replicate the phone.prc need to be inactive. The replicant version of phone.prc in your backup folder will be out of date. This will get reinstalled into RAM when you restore your data. Re-hack the new version of Phone.prc if you want but throw out the old one.
    Many of the tricking-out apps listed on the Treo Utilities forum are potential hazards during the upgrade -

    You can also get into a nasty loop of running the updater multiple times if you press hotsync twice during the initial HotSync screen in the Windows installer. I posted a solution to this at the link above.

    I have a new little app in ROM called Sounds now - it is a new view into the ringtone manager. I have the SMS privacy preference also. I just installed EasyNotes and am recording silly gibberish from the radio. Hard to say if the received call audio is any different - it may be a little sharper.

    One other little matter: If you use GoodLink, you will need to reactivate your account by either restore from SD card or via your helpdesk. Don't do this upgrade in the field without some preparation unless you like email silence. It's easy to get going again but you could get caught out if you installed the update while on the road and were not able to reactivate until you got back to base.
    Last edited by Poryphyron; 05/17/2004 at 08:45 PM.
  10. #10  
    3 hours of hacking later and I have firmware 3.05 installed, most of my apps back, and only my Lightwav and Zlauncher preferences to recreate.

    Worth it for a 0.01 increment in firmware..? I think not.

    /bleeding edge of technology, over and out.
  11. #11  
    lol my sentiments exactly. i get into that infinite loop thing and none of those files i am supposed to delete are in there. i just went back to the old version.
  12. #12  
    This update has been our for some time, I am in Australia and have updated 12 of our 47 phones. All is well so far but I am working on the don't fix something that's not stuffed idea.

    Palmone Australia won't talk warranty unless you have done the update!
    Welcome to Palmone, tomorrows bugs today!!!
  13. #13  
    yah if it ain't broke don't fix it. cus the update will break it for you.
  14. #14  
    I have a Treo 600 with Verizon and I have had soft reset problems with the SMS and other random programs... I have already sent one phone back. I realize that this is probably happening to many of you, but I can't seem to find the solution after searching the threads. My apologies for bogging down the forum, but where do I go to fix this soft reset problem???

    Thanks so much... still love the phone!


Posting Permissions