Results 1 to 6 of 6
  1.    #1  
    Hi. I just got my Treo 600 last week from Sprint.

    I used to be able to sync my older Palm VII to a central Palm Desktop here at work using the Lansync/Network Sync options of Hotsync. On the Treo, there are only 3 options under the menu:
    - Conduit Setup
    - Connection Setup
    - About HotSync

    The Lansync preferences, etc. are not there, nor can I find anyway under these existing menus to specify an IP for the desktop I want to sync with.

    Sprint has been no help, as their engineers say the "Lansync Prefs" menu does show up on their emulator, and does show up on their "test" device. Any idea what might be happening? The Hotsync version is 5.0. Installing the updated OS that was released recently didn't affect this part at all. Thanks in advance for any info.

    -- Don
  2. #2  
    Myself and a few other users have noticed this, it appears to affect certain devices, but not others. If you do a hard reset you will get the options back, but then if you restore from backup you will lose the options again, haven't found any way to permanantly get the options back, let me know if you find a way.
  3. 7zero's Avatar
    214 Posts
    Global Posts
    227 Global Posts
    Strange. I have all the connections. Have you tried setting up a "Custom Connection"?

    I'm running a SPCS (CDMA) Treo 600, Rev. C, 1.10-SPR
  4.    #4  
    Originally posted by 7zero
    Strange. I have all the connections. Have you tried setting up a "Custom Connection"?

    I'm running a SPCS (CDMA) Treo 600, Rev. C, 1.10-SPR
    Mine is a Treo600-1.10-SPR Rev C as well.

    Under the Custom Connection, there is a pulldown for PC, Modem, or Local Network.

    Even if I select Local Network, all the Detail screens look exactly like the PC connection (showing only Speed and Flow Control pulldowns)..nothing referring to any network-related items like IP address or name. These settings do not seem to affect the behavior of my Hotsync.
  5.    #5  
    Thanks rgreene07! You gave me the key info I needed to figure this out.

    I hadn't thought of checking the device after a hard reset, but before the restore. Sure enough, after a hard reset, the Lansync options are there. After restoring the Treo from the backup, they disappear.

    I figured there was an incompatible file that was getting restored onto the Treo. After some trial and error, I narrowed it down to a file called NetSync.PRC. When I removed this from the backup directory before the next restore, the menus were there and I was able to sync over the network just fine. Looking at the Backup directory after the Hotsync, a new version had not appeared, so I believe that this is a file that isn't even present in the stock version of OS version 5.0. It was a carryover from my older Palm VII backup.

    So to summarize the procedure to clear this permanently, I'd suggest the following steps:

    1. Backup your Treo using Hotsync.
    2. Do a hard reset on the device.
    3. Find the "Backup" directory under your user. For me it was C:\Program Files\Palm\KarkD\Backup
    4. Move the file NetSync.PRC somewhere outside the Palm environment (like c:\My Documents).
    5. Now perform the restore like normal.

    I found that this procedure left the Lansync menus intact. I was then able to program in the remote PC's IP address using the "Primary PC Setup" menu, and it all worked fine. Everything else seems to work as expected, so I think this is the right answer.

    Obviously your miles may vary -- as in I'm not responsible, #include <stddisclaimer.h> and all that other fun stuff . Make sure you make copies of all your old files/directories and you should be OK.

    Thanks again for the help and suggestions. These groups are really useful.

    -- Don
  6. #6  
    Hey thanks dkark, now I have mine working as well. I had been to lazy before to figure out which file was being copied over and screwing things up. Although I could have done without the c++ code at the end, I should be doing CS homework.

Posting Permissions