Results 1 to 3 of 3
  1.    #1  
    My phone froze last night so I did a soft reset and it is now at the palm powered screen and remains there no matter what i do...i've tried a hard reset and it prompts me to erase data but it goes back to palm powered... it's been like that all night up til now... waiting for the battery to drain... any suggestions? i'm returning this pos.
  2. #2  
    Did you answer yes to erasing data? If you have a backup, you can erase all data and see if that solves your problem, then reload your applications from backup. If you wait for the battery to drain, you'll have a long wait.

    And if you answered yes to erase data, and still get the palm powered logo, then your unit is probably faulty.
  3. #3  
    I had my TREO for 2.5 days when it froze up. Touch screen would no longer respond. Soft boot, hard boot, system boot. No dice. Took it to Sprint. They agreed and are sending me a 'new' one (we'll see how new) in a day or two.

    SOL until then.

Posting Permissions