Page 4 of 4 FirstFirst 1234
Results 61 to 65 of 65
  1. #61  
    I am currently on my third Unleash product.

    First one worked great for 3 days then would only keep a charge for 10 minutes.

    2nd one wouldn't pair up.

    3rd one works every other time but when working audio is very distorted. Will be sending this one back shortly.

    Brigette and Ron are great and have been a pleasure to deal with. Both are great customer service folks.

    Really liked the headset but now may go to Bluetooth...was checking out the BlueTrek. It appears small and light.
    Last edited by PeteC; 01/28/2004 at 07:27 AM.
  2. willp2's Avatar
    115 Posts
    Global Posts
    116 Global Posts
    Originally posted by Shain
    Has anyone tried any of these headsets
    I am interested in the G2 and the Dongle

    It seems a lot smalller than the the unleash or the Fonegear
    Anyone know if you can use the dongle with any Bluetooth headset? It seems like you should be able to, but it would be nice to know for sure. It would be nice to be able to consider some of the other BT headsets out there.
  3. #63  
    Just purchased the Blue Trek 1.2 with dongle and accessories. Will write up a quickie review once I start playing with it.
  4. #64  
    I just got my 2nd Unleash and it seems (so far) to be working out. For sure if this one tanks then it goes back for good. My initial problem was with the caller on the other end saying I sounded like I was breaking up, there was a buzz, or other audio problems. They did send out another right away, but I am slightly skeptical of quality testing/control.
  5. #65  
    I have been following the various threads on the Unleash product and have found a couple things... if I use the unit at my computer, I get varying degrees of distortion and very limited use. If I move away from my monitor, no problem. Possibly the emf from my "old style" monitor is too much for the limited power of this unit. Other than that, I have had very good results.

    any one else duplicate this?
Page 4 of 4 FirstFirst 1234

Posting Permissions