Page 1 of 3 123 LastLast
Results 1 to 20 of 45
  1.    #1  
    Has anyone else read this thread on how to get free, unlimited data with T-mobile?

    I've tried it, but can't seem to get it to work with my Treo 270. Has anyone else tried?


  2. #2  
    I don't know much about the free internet, but to get my 180 to work with T-Zones took a few changes. In preferences/network create a new service (The original tmoble internet service didn't work right with t-zones). Set the connection to GPRS, leave user name and password blank, set APN to Under details/advanced set ip address to automatic and set the check box for query dns. This should allow you to access the internet with the Blazer browser. To acces the t-zones wap site you need a wap browser that can use a gateway (Blazer can't). The best wap browser that has a gateway that I have found is jBrowser from Jataayu Software ( it costs about $15 and you can get a 1 month trial) You need to set the gateway to, the port to 9201 and the home page to I also found the Eudora Internet suite to be extremely valuable. It comes with an email client and a browser. The email client can attach to any pop email server on the internet and supports encripted connections (hint if your server uses a non-standard port put a colon and port number after the servername) If you have t-zones set t-zones to send you a sms message when you receive an email so you don't have to check your email all the time (this t-zones feature however is unreliable at times). The eudora browser is better at accessing the general internet than blazer is, but it doesn't support graphics. Hope this helps, report back as to whether this works for free internet.
  3. #3  
    Using jbrowser I was able to get wap access w/ just the free internet.

    I was unable to get blazer to work though
  4. #4  
    Same here. I think this is because the Blazer automatically connects via a special proxy, and that is blocked with the free WAP T-Mobile settings. I'm guessing other browsers should work.
  5. #5  
    So I installed a proxyless browser and the I can browse webpages and check email. One question though.

    Is this the normal speed of GPRS or is this free connection slower?
  6. #6  
    What proxyless browser did you install?

    And ack... I must admit, GPRS *DOES* seem slow, at least with this free WAP-based access. Maybe because so many of us greedy souls have signed up
  7. #7  
    eudora... xiino... EIS...

    When it's connecting, if you hit the down key it still says connecting at 9600 - I would have though that GPRS would be better than CSD.

    Guess I'm glad I never signed up for a data plan.
  8. #8  
    I must admit though (speed aside) it's pretty nifty to be posting this from my treo for free. FWIW, I'm using eudora web to post this.
  9. #9  
    I think I followed the directions to the letter, but I'm not having much success. The free wap wasn't listed on my T-mobile account, so I sent an email requesting it and it was added this morning (Mon, 12/8 -- now shows up for my account on the T-mobile website). I'm in Seattle, by the way.

    I created a new connection in network preferences, named it "WAP" for no particular reason, connection type is GPRS. No username or password is entered, the apn is

    Under details, Fallback is "none", IP Address is on auto (checked) and query DNS is checked.

    If I hit the 'connect' button on the network preferences screen, I get a "Connecting to WAP" window followed by "Signing on". The latter remains for a good ~30 seconds or so. It then gives an error window:

    Error: incomplete setup. Check phone number & username. (0x121A)

    I get this same result when I try to check email or browse the web with Eudora.

    Any suggestions would be greatly appreciated!
  10. #10  
    I had exactly the same problem, and the solution was NOT intuitive.

    Click on the PASSWORD field of the new network service you've created. Then, without typing anything, hit OK.

    NOW you should be able to log on. At least that did it for me
  11. #11  
    Whoo hoo! Thanks Adam! I tried your suggestion and it actually didn't at work at first. It is interesting to note that clicking on the password box changes the label from 'prompt' to 'unassigned'. That actually didn't work for me, but I went one step further and changed the password to a "space" and it works great now.

    Many, many thanks!
  12. #12  
    I'm really pleased that you were able to get GPRS working . Though the strange thing is... mine worked without entering a space (it still shows "unassigned"). Weird.

    But let me tell you, I was pullin' my hair out last night, spending literally hours scouring forums and troubleshooting. To my knowledge, no one else has mentioned this particular tip. I wonder how others got up and running!

    Anyway, now let's just keep our fingers crossed that T-Mobile is slow in closing the loophole .
  13. #13  
    Just want to add something, if you want to use the built in browser –Blazer, using the free T-Zones from T-Mobile, you can set-up the proxy on advance settings. Just type in one proxy address/IP from free proxy lists, like from or if you do a search from Google or Yahoo and look for “free proxy list”. Just remember to look for proxies with port 80. Happy browsing!
  14. #14  
    I still can't seem to get this to work, please tell me if I'm missing something. I've got a basic plus ($30) and under My Plan & Services it shows "Included WAP Access Active"

    I go into preferences and select the network tab and create a new service.
    Service: wap
    Connection GPRS
    User Name: (I leave it tap to enter)
    Password: (tap on it and tap ok to make it change from prompt to unassigned)
    initilizing...connecting to wap...signing on...connection error... "Error: incomplete setup. Check phone number & username."
    If I then tap on the username box and then tap ok and then try connecting again I get an "Error: Connection timed out"

    Any help would be GREATLY appreciated
  15. #15  
    try to look on the details then advanced settings, the IP address should be automatic then the Query DNS should also be checked. hope this helps.
  16. #16  
    Thanks for the reply edward21. IP Address and Query DNS are checked (by default both were checked on my treo). I tried unchecking and then rechecking them, but still no luck =(
    I had tmobile internet for $20 a month and that worked fine, but why pay for the full version when the free one has all I want. Anyone else have any ideas?
  17. #17  
    try to reset the unit. or you may want to try to change the serice name from wap to T-zones. I think that worked on my t68 before
  18. #18  
    I tried changing the service name to "T-zones" but that had no effect, also tried a soft reset with the same results. I'll give a hard reset a try tommorrow once I've had time to backup everything. Thanks again edward21.
  19. #19  
    Hi Edward 21,
    Thanks for all the info you posted. I was able to get online on my 270 using Blazer without a dataplan from Tmo. However, on a regular basis I'm unable to connect because I get an error message stating that my proxy is invalid. To circumvent this problem, I've to change my proxy IP address (the newest IP address I can get from and set it to port 80.
    Is there a way I can use a fixed IP address? Any other ideas?
  20. #20  
    I too have to change the proxy settings again. You may want to try searching free proxy list on google or yahoo, there's a lot of list on the net. I think there are some proxy server that are permanent, but I don't know their reliability and speed though. the one from free-proxy are a little bit faster, I think.
Page 1 of 3 123 LastLast

Posting Permissions