Results 1 to 11 of 11
  1.    #1  
    I'm trying to use a Treo 180 with the Fido pay as you go service in Canada, but I can't seem to get it to work. Has anyone successfully done this?
  2. sen
    sen is offline
    sen's Avatar
    6 Posts
    Works fine for me - except for WAP over GPRS, which should be available on the Fido prepaid service.

    Is your Treo 180 unlocked?

    Have you setup your SIM with Fido - do you have a phone number yet? If you have, does the phone "find" the network when you turn it on?

    Please describe what you've tried - and any results.
  3.    #3  
    I previously had a SIM card so I tried that, but I can't get the Treo unlocked (using the Tiger Direct system). So I keep getting the "Your phone cannot be used with this SIM card".

    Any help would be appreciated.
  4. #4  
    I purchased an unlocked Rogers 180 through ebay, and it works fine with FIDO. However the GPRS update won't work because Handspring only supports Rogers in Canada. (I tried to install the GPRS update but it cancelled out when it detected my FIDO card).

    I refuse to use WAP/internet anyway because of the ridiculous data costs, so I chose FIDO pay as you go because it's a lot cheaper than Rogers, despite the limited coverage outside Toronto.

    The units were a lot of Rogers 180s. I guess they didn't sell too many at $600 a pop, because the guy had over 100 to sell (he sold them all at $80-90 USD each

    Now to my point: try emailing him for the unlock code, maybe he'll charge you a small fee or something, just a guess. You can reach him at Randy Aquino []
  5. sen
    sen is offline
    sen's Avatar
    6 Posts
    hoodoo: Even if you don’t plan on using the data services, installing the GPRS upgrade might be a good idea since it supposedly adds, and updates several things. The following TreoCentral guide describes a procedure for installing the GPRS upgrade:

    According to other posters in the TreoCentral forums, this upgrade works fine with Fido – you can surf if you’re on a monthly plan.

    Saint: Sorry… can’t add anything else to what hoodoo has written.
  6. #6  

    Thanks, I'll give the update a try.

  7. #7  
    GPRS upgrade update...

    Well, upgrade was successful. I'm stuck with a serial cable at the office because we use NT, and my computer seemed to be slowish today, so the installation took ages (over an hour ++).

    I noticed immediately that my battery voltage jumped to over 3.8v. I must say I was curious that the voltage would drop to 1.7v fairly quickly while still indicating 100% before I did the upgrade. mentions in the upgrade overview that battery life does improve, BTW.

    Sen, I should have read your first post more closely

    Works fine for me - except for WAP over GPRS, which should be available on the Fido prepaid service.
    I called Fido, and they said I can't access GPRS on prepaid, but that I should be able to access WAP. Is this true? Then, searching further, it seems I will need to acquire a WAP browser, because Blazer won't handle this. I'm not ready to pay monthly yet for data services, but maybe you know something more about this issue. I'd like to know how to proceed if/when I set up data services at some point.

    Any other FIDO/Treo experts out there?

    Sorry, I'm new to the Treo, but not Palms or cell phones!

  8. sen
    sen is offline
    sen's Avatar
    6 Posts
    Success!!! After much searching on the net, fiddling with various setting, trying different browsers, and calling the fido CSRs, I finally have WAP access on my treo, with the fido prepaid service – this better be worth the money/time I spent .

    hoodoo: You were right. Essentially, you just need a “real” WAP browser – I’ll get to that…

    The following is based on third-hand research - I'm too lazy to read the actual WAP specifications - so please feel free to correct me (gently): Blazer can render WML – the markup language used in WAP, but does not “decompile” (decompress?) the page – which is part of the WAP specs.

    The only WAP browser, that I’ve tried, that can handle WAP "properly", is AUS WAP (I tried ver. 1.6). You can find it here:

    I used the following settings:

    Create a new Network service, or edit a current one, with the following settings (click Prefs icon under System menu, select Network).

    Connection: GPRS
    User Name: fido
    Password: fido

    Launch AUS WAP. Bring up the menu. Select Options -> Preferences. Use the following settings.

    Gateway Server:
    Gateway ID : leave blank
    Gateway password: leave blank

    Good luck.

    Anyone know of any good WAP sites. has links to canada411, and movie listings, but there must be more out there…

    Update: kbrowser, and jbrowser also seem to work. kbrowser is freeware, you can get it here:

    jbrowser, is a commercial product, and by far the best of the three WAP browers.

    Before you run out and spend any more money, from what I’ve seen of WAP so far, it really isn’t worth it: bad usability - too many steps to get to the information, and limited content.
    Last edited by sen; 11/11/2003 at 08:39 AM.
  9. #9  
    I can establish the connection, but it is always timing out, regardless if I connect through Network or directly from the AUS browser. Hmmmm...I guess I'll have to keep trying.

    Any suggestions?

  10. sen
    sen is offline
    sen's Avatar
    6 Posts
    Do you get an "Error: Connection timed out..." message when you are trying to establish a GPRS connection, or a "...request timed out..." error message when you are trying to access a WAP page with the AUS WAP browser?

    If the error occurs when you are trying to establish a GPRS connection: have you called fido to enable WAP over GPRS on your account - it's not enabled by default; try connecting again, and again - rarely do I connect on the first try... I don't know why, but usually on the second try it connects.

    If the error occurs while you are using the AUS WAP browser, try a different WAP site. I know (most of the links), and work, but some sites, like, and the Canadian Link on, time out. I don't know if it's because of a problem with AUS WAP browser - old, or buggy WAP rendering - or a problem with the sites.

    BTW, you can let the browser bring up the GPRS connection - the timing out was just a coincidence.

    Hope that helps.
  11. #11  
    I need to get my phone unlocked to work with Fido, currently on Rogers... any suggestions without paying huge coin? Tigerdirect method is a no-go. Rogers refuses to activate the phone on Pay-as-you-go, plus their prepaid is gsm only. PM me any info. Thanks.

Posting Permissions