Results 1 to 11 of 11
  1.    #1  
    Don't get me wrong, I love this device, but IMHO there are some serious issues that need addressing. I am starting this thread in an attempt to document the errors I have experienced and look for trends and share information with other users.

    The following information is based on the diagnostic function (Dial #*377).

    I have had the phone since Sat 25/10. So far I have had 4 crashes, where the Treo does its own internal soft reset, latest one this morning. 3 in "Phone" and 1 in "Messaging". All of them contained the same error message, namely:

    "HALRadioOmap.c, Line:300, Host Wake not asserted in time".

    Does anyone have any technical experience/access to the source code that might shed some light on this issue?

    Thanks in advance (and thanks to all who replied my previous post)

  2. #2  
    Not had this problem on any of my 3 Orange Treos.
  3. #3  
    A common question asked of people who are experiencing many crashes is:

    Have you upgraded to the 600 from an earlier model? If you have, the HotSync to transfer stuff from your old device to the new one will almost certainly have installed various bits and pieces which the 600 does not like. Many people have suggested a hard reset and start from scratch which seems to solve a multitude of problems.
  4.    #4  
    Nope, this is my first Treo 'experience'. I have installed the Orange PC software (hot sync) and I am using the Palm Desktop, not Notes or Outlook conduits. I did notice it install some new apps (Splash suite) on the phone during my first hotsync and I have uploaded Pocket Tunes. Thats all. I assumed these apps were ok seeing as they came with the bundled disk. I have to admit to not checking for latest versions or anything.

    SplashID v.2.56
    SplashMoney v.2.96
    SplashShopper v.2.55

    Also Zap & Klondike

    These error messages would seem to me to be symptomatic of version 1.0 software but I will check my hotsync logs tonite and post here.

    Thanks again to all, I really want this to work...I love it, even with its faults...

  5.    #5  
    Fault occured when I was in Phone, on the dial pad. I pressed the center button to bring up the recently dialled numbers. I highlighted one then pressed < (left) accidentally, it crashed and did a soft reset. It then 'hung' on the power up/down screen (the moutains of madness?) and I had to do another soft reset to bring it all back.

    I dialled #*377 and it reported the same fault as below (line:300 again) I reactivated wireless mode and all ok.

    I did notice complete loss of GPRS before the thing crashed, e.g. no black triangle.

    Anyone else...?

  6. #6  
    Just tried it on mine with, I'm afraid, no crash.
  7. #7  
    Call Orange and tell them "There is something wrong with my phone, please replace it."

    I.e., please don't fall into the trap of convincing yourself that it's a computer and computers are just inevitably buggy.

    Microsoft convinced us of that and we've been stuck with poor quality software ever since.

    If your VCR made strange noises and reset itself whenever you pressed rewind, you'd pack it up and take it back to the shop.

    This is also the only way to force Orage/Handspring to fix any issues.

    OK, I'll climb off the soapbox now...
  8.    #8  
    Well - this is the end of my first week with my Treo. Its crashed everyday but one. Same error EVERY time, "HALRadioOmap.c, Line:300, Host Wake not asserted in time". This mornings crash occured just turning off the keylock!!!

    I have removed all the apps that were installed with the first hotsync (apart from pocket tunes and docs/ssheets to go) and am now convinced the error is with the base OS. Not enough testing I reckon.

    Are there any palm developers out there with access to the source that can let me know what is occuring please? Orange support have been utterly useless, and of course you can't go back to HS as the supplier was Orange, but Orange don't know enough about it so talk to HS etc etc etc..

    (I still love it to pieces, the best bit of kit I have bought.)
  9. #9  
    If you haven't already tried it, perform a hard reset. This seems to have solved a number of problems for a number of people. It will, unfortunately, delete all apps/data currently installed, but that is the point - if something has been installed which the OS does not like, it will be blasted as well.

    When you reinstall stuff, try to stick to tried and tested applications - there are plenty of posts listing these. If you can be bothered, install stuff gradually over a few days to see if there is a particular application causing the problem.
  10. #10  
    Given that you haven't really made significant changes to the default configuration and the error message from the HALRadioOMap, I really suspect this to be a hardware problem in the radio.

    You should really call Orange and ask them for a replacement.
  11. jnei's Avatar
    1 Posts
    I got the same problme with HALRadioOmap.c. How to start from scratch? any help will be appreciated.

Posting Permissions